summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-07-10 16:59:01 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-07-10 16:59:01 (GMT)
commit1c50b2d2a54fc1c0b3f39c5d08ab80c5f8b5e64e (patch)
tree736aea611382d58350f4c858d2ad1fccb6e68c7e /abs/core-testing/LinHES-config
parentd11f52d5ca56e33f0c462110e58460dafe6e7256 (diff)
downloadlinhes_pkgbuild-1c50b2d2a54fc1c0b3f39c5d08ab80c5f8b5e64e.zip
linhes_pkgbuild-1c50b2d2a54fc1c0b3f39c5d08ab80c5f8b5e64e.tar.gz
linhes_pkgbuild-1c50b2d2a54fc1c0b3f39c5d08ab80c5f8b5e64e.tar.bz2
Linhes-config: set remote type to none when auto detect falls through
Diffstat (limited to 'abs/core-testing/LinHES-config')
-rwxr-xr-xabs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/install_functions.sh12
2 files changed, 11 insertions, 3 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index a31f7d4..5ad1a9c 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.0
-pkgrel=52
+pkgrel=53
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo python-pexpect python-netifaces LinHES-timezone)
diff --git a/abs/core-testing/LinHES-config/install_functions.sh b/abs/core-testing/LinHES-config/install_functions.sh
index 6775337..9b39437 100755
--- a/abs/core-testing/LinHES-config/install_functions.sh
+++ b/abs/core-testing/LinHES-config/install_functions.sh
@@ -11,7 +11,7 @@ CMDLINE=$(cat /proc/cmdline)
hostname=`hostname`
MYSQLCMD_C="mysql -u$MYTHDBUSER -p$MYTHTVPASSWD mythconverg -B --exec"
BASE=""
-
+found_remote=1
function update_db_settings () {
@@ -117,6 +117,7 @@ do
esac
fi
update_db_settings HostReceiverType $FoundReceiverType
+ found_remote=0
setupremote
break
fi
@@ -125,7 +126,7 @@ done
function scan_for_usb_remote () {
-found_remote=1
+#found_remote=1
printhl " Scanning for usb receiver/remote"
while read line
do
@@ -149,6 +150,13 @@ if lsusb | grep 04d8:0004 > /dev/null 2>/dev/null
then
/usr/bin/PyroUsb.py > /dev/null 2>&1 &
fi
+
+if [ $found_remote -eq 1 ]
+then
+#No remote found_remote
+ update_db_settings HostRemoteType "no_remote"
+fi
+
}
function rest_of_network () {