summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-05-07 01:29:05 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-05-07 01:29:05 (GMT)
commit246c0471433375b63988e3fb2ca69c1670bed340 (patch)
tree5eea9b987c626a96c9a69a2ec1afdb8596af1914 /abs/core-testing/LinHES-config
parenta068650007ddd8a5fe3d868d92d237116c5f691c (diff)
downloadlinhes_pkgbuild-246c0471433375b63988e3fb2ca69c1670bed340.zip
linhes_pkgbuild-246c0471433375b63988e3fb2ca69c1670bed340.tar.gz
linhes_pkgbuild-246c0471433375b63988e3fb2ca69c1670bed340.tar.bz2
mv_install: add install type for format_disk.
Add try:except for MVROOT on full_install
Diffstat (limited to 'abs/core-testing/LinHES-config')
-rwxr-xr-xabs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/mv_install.py7
2 files changed, 7 insertions, 2 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 64929f0..44fe66f 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=1.0
-pkgrel=405
+pkgrel=407
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted )
diff --git a/abs/core-testing/LinHES-config/mv_install.py b/abs/core-testing/LinHES-config/mv_install.py
index f9359e4..33a74a4 100755
--- a/abs/core-testing/LinHES-config/mv_install.py
+++ b/abs/core-testing/LinHES-config/mv_install.py
@@ -787,6 +787,11 @@ def restore_default_settings():
def full_install(hostoptions):
logging.info("______Start of full install______")
+ try:
+ MVROOT=os.environ["MV_ROOT"]
+ except:
+ logging.debug(" MVROOT was not defined, using the default value")
+ MVROOT="/usr/MythVantage"
try:
os.remove("/tmp/.this_is_upgrade")
@@ -806,7 +811,7 @@ def full_install(hostoptions):
statusmsg="Preparing %s" %( hostoptions["rootdisk"])
update_status(statusmsg)
progress(2)
- format_disk()
+ format_disk("install")
# Mount partitions