summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-19 21:44:03 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-19 21:44:03 (GMT)
commit79daa29002e02579e84a5bb7ca895be2395a7fce (patch)
tree402a6ba34feff4c9d144b65bfe6e6d0f16782485 /abs/core-testing/LinHES-config
parentdb90030979f646114470d9a2c6f5e394d3af181f (diff)
downloadlinhes_pkgbuild-79daa29002e02579e84a5bb7ca895be2395a7fce.zip
linhes_pkgbuild-79daa29002e02579e84a5bb7ca895be2395a7fce.tar.gz
linhes_pkgbuild-79daa29002e02579e84a5bb7ca895be2395a7fce.tar.bz2
Linhes-config/system: add option to stop tweaker from running.
Diffstat (limited to 'abs/core-testing/LinHES-config')
-rw-r--r--abs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/mv_install.py7
2 files changed, 5 insertions, 4 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 77b9563..ed2079d 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.0
-pkgrel=86
+pkgrel=88
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted
diff --git a/abs/core-testing/LinHES-config/mv_install.py b/abs/core-testing/LinHES-config/mv_install.py
index 56118c1..7d72c22 100755
--- a/abs/core-testing/LinHES-config/mv_install.py
+++ b/abs/core-testing/LinHES-config/mv_install.py
@@ -844,7 +844,9 @@ def special_hardware_check():
typefile.close()
except:
logging.debug("Couldn't write to file: ", typefile)
-
+ if re.match("no_meth",item) != None :
+ cmd = " touch %s%s/.no_meth" %(data_config.MOUNTPOINT, data_config.MYTHHOME)
+ runcmd(cmd)
def swapsearch():
#currently unused!
@@ -1038,12 +1040,11 @@ def full_install(hostoptions):
cmd = "chroot %s %s/bin/restore_default_settings.sh -c ACCESSCONTROL " %(data_config.MOUNTPOINT, MVROOT)
runcmd(cmd)
umount_bind_chroot()
- #cmd = " chroot %s %s/bin/systemconfig.sh advanced, user" %(data_config.MOUNTPOINT, MVROOT)
- #runcmd(cmd)
cmd = " touch %s%s/.configure" %(data_config.MOUNTPOINT, data_config.MYTHHOME)
runcmd(cmd)
cmd = " chmod 777 %s%s/.configure" %(data_config.MOUNTPOINT, data_config.MYTHHOME)
runcmd(cmd)
+
msg = "Done"
update_status(msg)
cp_and_log("/tmp/mythvantage_install.log", data_config.MOUNTPOINT+"/var/log/mythvantage_install.log")