summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-07-14 02:25:24 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-07-14 02:25:24 (GMT)
commitb08d687d99a8df0e2c0be8e1746a8456518edb8e (patch)
tree840fed35616837616ae0c509bdcc79301840902b /abs/core-testing/LinHES-config
parenta6476c77e1cc295d4b8debaea2d0dfbeae0f7b01 (diff)
parent4c71823825d08c1cc2219d22a6d3fe190e158a09 (diff)
downloadlinhes_pkgbuild-b08d687d99a8df0e2c0be8e1746a8456518edb8e.zip
linhes_pkgbuild-b08d687d99a8df0e2c0be8e1746a8456518edb8e.tar.gz
linhes_pkgbuild-b08d687d99a8df0e2c0be8e1746a8456518edb8e.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/core-testing/LinHES-config')
-rwxr-xr-xabs/core-testing/LinHES-config/PKGBUILD4
-rwxr-xr-xabs/core-testing/LinHES-config/install_functions.sh77
2 files changed, 68 insertions, 13 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 5ad1a9c..0094f57 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,9 +1,9 @@
pkgname=LinHES-config
pkgver=2.0
-pkgrel=53
+pkgrel=58
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
-depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo python-pexpect python-netifaces LinHES-timezone)
+depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo python-pexpect python-netifaces LinHES-timezone python-iplib)
arch=('i686')
source=(mv_install.py mv_config.py mythinstall.bin myth_user_call file_time_offset.py install-ui.xml install_proxy.sh install_functions.sh systemconfig.sh install_db_chroot.sh restore_default_settings.sh xconfig.sh timezip.py soundconfig.sh LinHES-release issue MythVantage.sh create_master.sh build_diskless.sh networkconfig.sh autocard.py restore_km_db_chroot.sh README mv_advanced.py mv_common.py mv_ir.py mv_misc.py mv_network.py mv_screensaver.py mv_smolt.py mv_software.py mv_webuser.py mv_hostype.py systemconfig.py myth_user_call.py)
diff --git a/abs/core-testing/LinHES-config/install_functions.sh b/abs/core-testing/LinHES-config/install_functions.sh
index 6775337..ea9e61c 100755
--- a/abs/core-testing/LinHES-config/install_functions.sh
+++ b/abs/core-testing/LinHES-config/install_functions.sh
@@ -11,7 +11,7 @@ CMDLINE=$(cat /proc/cmdline)
hostname=`hostname`
MYSQLCMD_C="mysql -u$MYTHDBUSER -p$MYTHTVPASSWD mythconverg -B --exec"
BASE=""
-
+found_remote=1
function update_db_settings () {
@@ -117,6 +117,7 @@ do
esac
fi
update_db_settings HostReceiverType $FoundReceiverType
+ found_remote=0
setupremote
break
fi
@@ -125,7 +126,7 @@ done
function scan_for_usb_remote () {
-found_remote=1
+#found_remote=1
printhl " Scanning for usb receiver/remote"
while read line
do
@@ -149,14 +150,21 @@ if lsusb | grep 04d8:0004 > /dev/null 2>/dev/null
then
/usr/bin/PyroUsb.py > /dev/null 2>&1 &
fi
+
+if [ $found_remote -eq 1 ]
+then
+#No remote found_remote
+ update_db_settings HostRemoteType "no_remote"
+fi
+
}
function rest_of_network () {
#netmask
- echo $CMDLINE | grep -q netmask
+ echo $CMDLINE | grep -q cnetmask
if [ $? -eq 0 ]
then
- TEMPVAR=${CMDLINE#*netmask=}
+ TEMPVAR=${CMDLINE#*cnetmask=}
NETMASK=${TEMPVAR%% *}
/sbin/ifconfig eth0 $IP netmask $NETMASK
nm=`/usr/bin/nmconv.py -obits $NETMASK`
@@ -167,10 +175,10 @@ function rest_of_network () {
printhl " Netmask not found"
fi
#gateway
- echo $CMDLINE | grep -q gateway
+ echo $CMDLINE | grep -q cgateway
if [ $? -eq 0 ]
then
- TEMPVAR=${CMDLINE#*gateway=}
+ TEMPVAR=${CMDLINE#*cgateway=}
GATEWAY=${TEMPVAR%% *}
/sbin/route add default gw $GATEWAY
update_db_settings HostGW${MYTHDEFAULT} "$GATEWAY"
@@ -179,10 +187,10 @@ function rest_of_network () {
fi
#dns
- echo $CMDLINE | grep -q dns
+ echo $CMDLINE | grep -q cdns
if [ $? -eq 0 ]
then
- TEMPVAR=${CMDLINE#*dns=}
+ TEMPVAR=${CMDLINE#*cdns=}
DNS=${TEMPVAR%% *}
echo "nameserver $DNS" >> /etc/resolv.conf
update_db_settings HostDNS${MYTHDEFAULT} "$DNS"
@@ -192,10 +200,10 @@ function rest_of_network () {
}
function init_network {
- echo $CMDLINE |grep -q netdev
+ echo $CMDLINE |grep -q cnetdev
if [ $? -eq 0 ]
then
- TEMPVAR=${CMDLINE#*netdev=}
+ TEMPVAR=${CMDLINE#*cnetdev=}
MYTHDEFAULT=${TEMPVAR%% *}
else
MYTHDEFAULT="eth0"
@@ -211,7 +219,7 @@ function init_network {
update_db_settings HostActiveonboot${MYTHDEFAULT} 1
update_db_settings HostNetDevice ${MYTHDEFAULT}
- TEMPVAR=${CMDLINE#*ip=}
+ TEMPVAR=${CMDLINE#*cip=}
IP=${TEMPVAR%% *}
if [ "$IP" == "dhcp" ]
then
@@ -224,6 +232,53 @@ function init_network {
rest_of_network
fi
fi
+
+
+
+
+}
+
+function dev_up_check(){
+ /sbin/ifconfig $1 1>/dev/null 2>/dev/null
+ status=$?
+ if [ $status -eq 1 ]
+ then
+ return 0
+ else
+ devip=`/sbin/ifconfig | grep -C1 $1| grep inet|grep -v inet6 | cut -d: -f2 | awk '{ print $1}'`
+ if [ "x$devip" = "x" ]
+ then
+ return 1
+ else
+ return 0
+ fi
+ fi
+}
+
+function request_dhcp(){
+ for ndev in eth0 eth1 wlan0 wlan1 ath0
+ do
+ dev_up_check $ndev
+ status=$?
+ if [ $status -eq 1 ]
+ then
+ #interface is down, lets see if dhcp responds
+ dhcpcd -Td -t2 $ndev > /tmp/dhcpinfo.$ndev
+ TEMPVAR=`grep IPADDR /tmp/dhcpinfo.$ndev |cut -d\' -f2`
+ if [ ! x$TEMPVAR = x ]
+ then
+ update_db_settings HostIP$ndev "$TEMPVAR"
+ TEMPVAR=`grep NETMASK /tmp/dhcpinfo.$ndev |cut -d\' -f2`
+ nm=`/usr/bin/nmconv.py -obits $TEMPVAR`
+ TEMPVAR="/$nm $TEMPVAR"
+ update_db_settings HostNETMASK$ndev "$TEMPVAR"
+ TEMPVAR=`grep GATEWAYS /tmp/dhcpinfo.$ndev |cut -d\' -f2`
+ update_db_settings HostGW$ndev "$TEMPVAR"
+ TEMPVAR=`grep DNSSERVERS /tmp/dhcpinfo.$ndev |cut -d\' -f2`
+ update_db_settings HostDNS$ndev "$TEMPVAR"
+ fi
+ fi
+ done
}
function init_remote {