summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-config
diff options
context:
space:
mode:
authorBob Igo <bob@stormlogic.com>2009-08-06 18:35:06 (GMT)
committerBob Igo <bob@stormlogic.com>2009-08-06 18:35:06 (GMT)
commitc4dc62d1e5ccbb602ea9d1e68cd2504b2629a680 (patch)
treeb48cc3e16eac49bee46671559f8eefcf63ca993e /abs/core-testing/LinHES-config
parentfd6a8d9904f68ae7fc174a6e0a7ac6f8ccab283f (diff)
downloadlinhes_pkgbuild-c4dc62d1e5ccbb602ea9d1e68cd2504b2629a680.zip
linhes_pkgbuild-c4dc62d1e5ccbb602ea9d1e68cd2504b2629a680.tar.gz
linhes_pkgbuild-c4dc62d1e5ccbb602ea9d1e68cd2504b2629a680.tar.bz2
mechanism to remember special hardware options now implemented
Diffstat (limited to 'abs/core-testing/LinHES-config')
-rwxr-xr-xabs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/mv_install.py13
2 files changed, 14 insertions, 1 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 89096ea..5aeeb7d 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.0
-pkgrel=70
+pkgrel=72
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted
diff --git a/abs/core-testing/LinHES-config/mv_install.py b/abs/core-testing/LinHES-config/mv_install.py
index ab7c644..0b34650 100755
--- a/abs/core-testing/LinHES-config/mv_install.py
+++ b/abs/core-testing/LinHES-config/mv_install.py
@@ -831,6 +831,19 @@ def special_hardware_check():
for module in modulelist.split(','):
add_to_modulelist(module)
+ if re.match("type",item) != None :
+ logging.debug(" Found special hardware type")
+ try:
+ typefile = open(data_config.MOUNTPOINT + "/myth/.special_hardware_type", 'w')
+ typelist = item.split("=")[1]
+ # there should be only one special hardware type, but this will handle multiples, just in case
+ for type in typelist.split(','):
+ typefile.write(type)
+ typefile.write("\n")
+ typefile.close()
+ except:
+ logging.debug("Couldn't write to file: ", typefile)
+
def swapsearch():
#currently unused!