summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-system/bin/mythrestore
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-06-28 20:22:05 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-06-28 20:22:05 (GMT)
commit50393bfc3f7d530ea28bb3a5b22c4ee5704d7f16 (patch)
tree5926ca994806f944b2f4ba7a1a343898b5fcecbc /abs/core-testing/LinHES-system/bin/mythrestore
parentd6700409fe40996d8185e25c7c375a1a8c250864 (diff)
parent25d4840e95d5e669f9e09ce23615eaa5051a247e (diff)
downloadlinhes_pkgbuild-50393bfc3f7d530ea28bb3a5b22c4ee5704d7f16.zip
linhes_pkgbuild-50393bfc3f7d530ea28bb3a5b22c4ee5704d7f16.tar.gz
linhes_pkgbuild-50393bfc3f7d530ea28bb3a5b22c4ee5704d7f16.tar.bz2
Merge branch 'master' of mihanson@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/LinHES-system/bin/mythrestore')
-rwxr-xr-xabs/core-testing/LinHES-system/bin/mythrestore11
1 files changed, 10 insertions, 1 deletions
diff --git a/abs/core-testing/LinHES-system/bin/mythrestore b/abs/core-testing/LinHES-system/bin/mythrestore
index 0ab5c86..447b0b8 100755
--- a/abs/core-testing/LinHES-system/bin/mythrestore
+++ b/abs/core-testing/LinHES-system/bin/mythrestore
@@ -5,6 +5,15 @@
echo 1>&2 "Can not load common settings!"
exit 1
}
+
+. /etc/osd_cat.cfg || {
+ color=yellow
+ outline=2
+ outlinecolour=black
+ shadow=0
+ shadowcolour=black
+ font="-adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-*"
+}
#----------------------------------------------------------------------------
# Function to display status onscreen
@@ -19,7 +28,7 @@ osd()
TEXT="\n"$TEXT
done
fi
- printf "$TEXT" | osd_cat --lines=6 --pos=middle --align=center --delay=$2 --color white -O 2 -u black -f -adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-* &
+ printf "$TEXT" | osd_cat --lines=6 --pos=middle --align=center --delay=$2 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
}
do_file_updates() { # A function because we need to do this in two places