summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/aspell/aspell.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-12 19:19:50 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-12 19:19:50 (GMT)
commit6c619a60fd89b5e75a93cff06977c552ddf1e621 (patch)
tree630ca50ea1c128c4be85ce920ecf034c561bf7fe /abs/core-testing/aspell/aspell.install
parent0b2b9b97e95f8f8bfda1d1fe09136d121cd0750d (diff)
parent634dff8fdd0a9c866c92f0020f282c23d1a438d8 (diff)
downloadlinhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.zip
linhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.tar.gz
linhes_pkgbuild-6c619a60fd89b5e75a93cff06977c552ddf1e621.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Conflicts: abs/core-testing/LinHES-config/PKGBUILD
Diffstat (limited to 'abs/core-testing/aspell/aspell.install')
-rw-r--r--abs/core-testing/aspell/aspell.install23
1 files changed, 19 insertions, 4 deletions
diff --git a/abs/core-testing/aspell/aspell.install b/abs/core-testing/aspell/aspell.install
index b635a4a..2747f02 100644
--- a/abs/core-testing/aspell/aspell.install
+++ b/abs/core-testing/aspell/aspell.install
@@ -1,8 +1,23 @@
+infodir=/usr/share/info
+filelist=(aspell.info aspell-dev.info)
+
post_install() {
- echo "NOTE: aspell comes with no default dictionary"
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+ echo "==> aspell comes with no default dictionary"
+}
+
+post_upgrade() {
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
}
-op=$1
-shift
+pre_remove() {
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
-[ "$(type -t "$op")" = "function" ] && $op "$@"
+# vim:set ts=2 sw=2 et: