summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/aufs
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-28 07:34:16 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-28 07:34:16 (GMT)
commit5d22477377dff808644fffa9566134a427db2772 (patch)
tree34000ef35c2316756a3f575bbab9165d69f5ff96 /abs/core-testing/aufs
parent076462b7305c420798e19edaa11885488acd1627 (diff)
downloadlinhes_pkgbuild-5d22477377dff808644fffa9566134a427db2772.zip
linhes_pkgbuild-5d22477377dff808644fffa9566134a427db2772.tar.gz
linhes_pkgbuild-5d22477377dff808644fffa9566134a427db2772.tar.bz2
Updated, recompiled to reflect new kernel.
Diffstat (limited to 'abs/core-testing/aufs')
-rw-r--r--abs/core-testing/aufs/PKGBUILD19
-rw-r--r--abs/core-testing/aufs/aufs.install6
2 files changed, 14 insertions, 11 deletions
diff --git a/abs/core-testing/aufs/PKGBUILD b/abs/core-testing/aufs/PKGBUILD
index 37ae95f..f0270fe 100644
--- a/abs/core-testing/aufs/PKGBUILD
+++ b/abs/core-testing/aufs/PKGBUILD
@@ -1,22 +1,21 @@
-# $Id: PKGBUILD 15519 2008-10-14 07:05:41Z thomas $
+# $Id: PKGBUILD 22431 2008-12-26 20:13:34Z tpowa $
# Contributor: Paul Mattal <paul@mattal.com>
# Maintainer: Paul Mattal <pjmattal@elys.com>
pkgname=aufs
-pkgver=20081012
-pkgrel=2
-_kernver='2.6.27-ARCH'
+pkgver=20081226
+pkgrel=1
+_kernver='2.6.28-ARCH'
pkgdesc="Another Unionfs Implementation that supports NFS branches"
arch=('i686' 'x86_64')
url="http://aufs.sourceforge.net/"
license=('GPL2')
-depends=('kernel26>=2.6.27' 'kernel26<2.6.28' 'glibc' 'aufs-utils=20081012')
+depends=('kernel26>=2.6.28' 'kernel26<2.6.29' 'glibc' 'aufs-utils=20081226')
install=$pkgname.install
-source=(ftp://ftp.archlinux.org/other/aufs/$pkgname-$pkgver.tar.gz)
+source=(ftp://ftp.archlinux.org/other/aufs/$pkgname-$pkgver.tar.bz2)
options=(!libtool !makeflags)
-md5sums=('fb5eaa69b2c7e6e521cb9a9cae9ac23f')
build() {
- cd $startdir/src/$pkgname || return 1
+ cd $srcdir/$pkgname || return 1
# Fix TMPFS_MAGIC error
sed 's|-le 26|-le 27|g' -i fs/aufs25/Makefile || return 1
@@ -42,6 +41,9 @@ build() {
# ???
sed -i 's|.*CONFIG_AUFS_SHWH =.*|CONFIG_AUFS_SHWH = y|' \
local.mk || return 1
+ # disable debug, broken in 2.6.28!
+ sed -i 's|CONFIG_AUFS_DEBUG = y|CONFIG_AUFS_DEBUG = |' \
+ local.mk || return 1
# configure for NFS by:
# 1) configure local.mk to use FILP and LHASH
@@ -66,3 +68,4 @@ build() {
}
# vim:set ts=2 sw=2 et:
+md5sums=('e855ed9edc16953028f22cae393690de')
diff --git a/abs/core-testing/aufs/aufs.install b/abs/core-testing/aufs/aufs.install
index 1a303d6..41cd96e 100644
--- a/abs/core-testing/aufs/aufs.install
+++ b/abs/core-testing/aufs/aufs.install
@@ -5,7 +5,7 @@ pre_install() {
post_install() {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
- KERNEL_VERSION=2.6.27-ARCH
+ KERNEL_VERSION=2.6.28-ARCH
depmod -v $KERNEL_VERSION > /dev/null 2>&1
/bin/true
}
@@ -13,7 +13,7 @@ post_install() {
post_upgrade() {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
- KERNEL_VERSION=2.6.27-ARCH
+ KERNEL_VERSION=2.6.28-ARCH
depmod -v $KERNEL_VERSION > /dev/null 2>&1
/bin/true
}
@@ -21,7 +21,7 @@ post_upgrade() {
post_remove() {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
- KERNEL_VERSION=2.6.27-ARCH
+ KERNEL_VERSION=2.6.28-ARCH
depmod -v $KERNEL_VERSION > /dev/null 2>&1
/bin/true
}