summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/avahi/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-10-20 20:14:55 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-10-20 20:14:55 (GMT)
commitb9d63c0f958a3c9fb54bb80599e5cda600c68f91 (patch)
treef3ab43b174339f87d32b6e0ab99e761916f2e650 /abs/core-testing/avahi/PKGBUILD
parent917f8e0bc9dcb481b5a44c19ca8348da1e241d27 (diff)
downloadlinhes_pkgbuild-b9d63c0f958a3c9fb54bb80599e5cda600c68f91.zip
linhes_pkgbuild-b9d63c0f958a3c9fb54bb80599e5cda600c68f91.tar.gz
linhes_pkgbuild-b9d63c0f958a3c9fb54bb80599e5cda600c68f91.tar.bz2
adding avahi and missing required packages.
-dbus-python -libdeamon
Diffstat (limited to 'abs/core-testing/avahi/PKGBUILD')
-rw-r--r--abs/core-testing/avahi/PKGBUILD65
1 files changed, 65 insertions, 0 deletions
diff --git a/abs/core-testing/avahi/PKGBUILD b/abs/core-testing/avahi/PKGBUILD
new file mode 100644
index 0000000..f98180b
--- /dev/null
+++ b/abs/core-testing/avahi/PKGBUILD
@@ -0,0 +1,65 @@
+# $Id: PKGBUILD 6066 2008-07-23 03:45:52Z douglas $
+# Maintainer: Travis Willard <travis@archlinux.org>
+
+pkgname=avahi
+pkgver=0.6.23
+pkgrel=1
+pkgdesc="A multicast/unicast DNS-SD framework"
+arch=('i686' 'x86_64')
+url="http://www.avahi.org/"
+license=('LGPL')
+#depends=('dbus>=1.1.20-1' 'libcap' 'libdaemon>=0.11' 'gdbm' 'glib2' 'expat')
+depends=('libcap' 'libdaemon>=0.11' 'gdbm' 'glib2' 'expat' 'dbus-python')
+optdepends=('qt3:Qt3 UI support' 'libglade:Avahi-discover-standalone'
+ 'nss-mdns:NSS support for mDNS')
+makedepends=('qt3' 'libglade' 'intltool')
+
+backup=(etc/avahi/avahi-daemon.conf)
+install=avahi.install
+conflicts=('howl' 'mdnsresponder')
+provides=('howl' 'mdnsresponder')
+replaces=('howl' 'mdnsresponder')
+options=('!libtool')
+source=(http://www.avahi.org/download/avahi-${pkgver}.tar.gz)
+
+build() {
+ [ -z "${QTDIR}" ] && . /etc/profile.d/qt3.sh
+ export MONO_SHARED_DIR=${startdir}/src/.wabi
+ mkdir -p ${MONO_SHARED_DIR}
+
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-qt4 \
+ --disable-monodoc \
+ --disable-doxygen-doc \
+ --disable-xmltoman \
+ --enable-compat-libdns_sd \
+ --enable-compat-howl \
+ --with-distro=archlinux \
+ --with-avahi-priv-access-group=network \
+ --disable-autoipd --disable-glib --disable-pygtk --disable-mono --disable-xmltoman
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+
+ rm -rf ${MONO_SHARED_DIR}
+
+ #fix capability
+ sed -i -e 's|$DAEMON -D |modprobe capability > /dev/null 2>\&1 ; $DAEMON -D |' ${startdir}/pkg/etc/rc.d/avahi-daemon
+
+ sed -i -e 's/netdev/network/g' ${startdir}/pkg/etc/dbus-1/system.d/avahi-dbus.conf
+
+ # howl and mdnsresponder compatability
+ cd ${startdir}/pkg/usr/include
+ ln -s avahi-compat-libdns_sd/dns_sd.h dns_sd.h
+ ln -s avahi-compat-howl howl
+ cd ${startdir}/pkg/usr/lib/pkgconfig
+ ln -s avahi-compat-howl.pc howl.pc
+ mkdir -p ${startdir}/pkg/usr/share/pixmaps
+# install -m 644 ${startdir}/src/gnome-nettool.png ${startdir}/pkg/usr/share/pixmaps/gnome-nettool.png
+}
+
+md5sums=('aab1a304851d8145ea5f6a85c10af9e9'
+ '42c2905307c7a5dc6ac4b75f4c3d65a3')
+