summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/cmake/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core-testing/cmake/PKGBUILD
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core-testing/cmake/PKGBUILD')
-rw-r--r--abs/core-testing/cmake/PKGBUILD33
1 files changed, 0 insertions, 33 deletions
diff --git a/abs/core-testing/cmake/PKGBUILD b/abs/core-testing/cmake/PKGBUILD
deleted file mode 100644
index 60e7f35..0000000
--- a/abs/core-testing/cmake/PKGBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# $Id: PKGBUILD 27686 2009-02-24 20:21:28Z pierre $
-# Maintainer: Pierre Schmitz <pierre@archlinux.de>
-# Contributor: damir <damir@archlinux.org>
-# Contributor: Konstantinos Pachnis <kpachnis@mes-direct.com>
-
-pkgname=cmake
-pkgver=2.6.3
-pkgrel=1
-pkgdesc="CMake is a cross-platform open-source make system"
-arch=('i686' 'x86_64')
-license=('custom')
-url="http://www.cmake.org"
-depends=('expat' 'xmlrpc-c')
-makedepends=('qt')
-optdepends=('qt: cmake-gui')
-source=("http://www.cmake.org/files/v2.6/$pkgname-$pkgver.tar.gz")
-md5sums=('5ba47a94ce276f326abca1fd72a7e7c6')
-
-build() {
- cd $srcdir/$pkgname-$pkgver
- ./bootstrap --prefix=/usr \
- --mandir=/share/man \
- --docdir=/share/doc/cmake \
- --system-libs \
- --qt-gui
- make || return 1
- make DESTDIR=$pkgdir install
-
- install -D -m644 Docs/cmake-indent.vim $pkgdir/usr/share/vim/indent/cmake-indent.vim
- install -D -m644 Docs/cmake-syntax.vim $pkgdir/usr/share/vim/syntax/cmake-syntax.vim
- install -D -m644 Docs/cmake-mode.el $pkgdir/usr/share/emacs/site-lisp/cmake-mode.el
- install -D -m644 Copyright.txt $pkgdir/usr/share/licenses/$pkgname/Copyright.txt
-}