summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/dbus-core/dbus.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
commit525753e4a1a139e088d8ac120b19fbab6c0aaaa6 (patch)
tree35cef28abb613da4f58e83f6abbe4bd4cfa244bf /abs/core-testing/dbus-core/dbus.install
parent592e3cad43ef12c53f523145d0fd981b54f2a049 (diff)
parentb172f79fadb565ecfbcec9508f9377d8618a4f4c (diff)
downloadlinhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.zip
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.gz
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/dbus-core/dbus.install')
-rw-r--r--abs/core-testing/dbus-core/dbus.install19
1 files changed, 11 insertions, 8 deletions
diff --git a/abs/core-testing/dbus-core/dbus.install b/abs/core-testing/dbus-core/dbus.install
index 85dd9a7..44f4475 100644
--- a/abs/core-testing/dbus-core/dbus.install
+++ b/abs/core-testing/dbus-core/dbus.install
@@ -5,17 +5,20 @@ post_install() {
dbus-uuidgen --ensure
}
-# arg 1: the new package version
-# arg 2: the old package version
post_upgrade() {
- post_install $1
+ post_install
#Make sure new rc script can shutdown running dbus
- [ -f var/run/dbus/pid ] && mv var/run/dbus/pid var/run/dbus.pid
+ if [ -f var/run/dbus/pid ]; then
+ mv var/run/dbus/pid var/run/dbus.pid
+ fi
}
-# arg 1: the old package version
-pre_remove() {
- usr/sbin/userdel dbus &>/dev/null
- usr/sbin/groupdel dbus &>/dev/null
+post_remove() {
+ if getent passwd dbus >/dev/null; then
+ usr/sbin/userdel dbus
+ fi
+ if getent group dbus >/dev/null; then
+ usr/sbin/groupdel dbus
+ fi
}