summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/e2fsprogs/e2fsprogs.install
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
commit525753e4a1a139e088d8ac120b19fbab6c0aaaa6 (patch)
tree35cef28abb613da4f58e83f6abbe4bd4cfa244bf /abs/core-testing/e2fsprogs/e2fsprogs.install
parent592e3cad43ef12c53f523145d0fd981b54f2a049 (diff)
parentb172f79fadb565ecfbcec9508f9377d8618a4f4c (diff)
downloadlinhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.zip
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.gz
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/e2fsprogs/e2fsprogs.install')
-rw-r--r--abs/core-testing/e2fsprogs/e2fsprogs.install23
1 files changed, 11 insertions, 12 deletions
diff --git a/abs/core-testing/e2fsprogs/e2fsprogs.install b/abs/core-testing/e2fsprogs/e2fsprogs.install
index e207eb4..f91d39f 100644
--- a/abs/core-testing/e2fsprogs/e2fsprogs.install
+++ b/abs/core-testing/e2fsprogs/e2fsprogs.install
@@ -1,21 +1,20 @@
- infodir=/usr/share/info
- filelist=(libext2fs.info.gz)
+infodir=/usr/share/info
+filelist=(libext2fs.info.gz)
- post_install() {
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
install-info $infodir/$file $infodir/dir 2> /dev/null
done
+}
- }
+post_upgrade() {
+ post_install $1
+}
- post_upgrade() {
- post_install $1
- }
-
- post_remove() {
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
install-info --delete $infodir/$file $infodir/dir 2> /dev/null
done
-
- }
-
+}