summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/esound
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-14 04:21:17 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-14 04:21:17 (GMT)
commit56ba5f3c5e06af89fd0bf710839635d3e5f1ac60 (patch)
tree468926664c785321a996db8beffc6a7a20d5e2a8 /abs/core-testing/esound
parentee7d8d75c14ed0ae36cc0e34ae150012c97e197d (diff)
downloadlinhes_pkgbuild-56ba5f3c5e06af89fd0bf710839635d3e5f1ac60.zip
linhes_pkgbuild-56ba5f3c5e06af89fd0bf710839635d3e5f1ac60.tar.gz
linhes_pkgbuild-56ba5f3c5e06af89fd0bf710839635d3e5f1ac60.tar.bz2
Moving several more packages to core, because they are dependencies of other packages in core.
xosd esound ftgl gdk-pixbuf glib gtklibmpg2 libvisual libxml-perl perl-xml-regexp projectm libdv libmng
Diffstat (limited to 'abs/core-testing/esound')
-rw-r--r--abs/core-testing/esound/PKGBUILD34
-rwxr-xr-xabs/core-testing/esound/esd37
-rw-r--r--abs/core-testing/esound/esd-0.2.38-alsa-drain.patch11
3 files changed, 82 insertions, 0 deletions
diff --git a/abs/core-testing/esound/PKGBUILD b/abs/core-testing/esound/PKGBUILD
new file mode 100644
index 0000000..b157aab
--- /dev/null
+++ b/abs/core-testing/esound/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 19662 2008-11-28 20:35:54Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+pkgname=esound
+pkgver=0.2.41
+pkgrel=1
+pkgdesc="Enlightened Sound Daemon"
+arch=(i686 x86_64)
+license=('LGPL')
+depends=('audiofile' 'tcp_wrappers' 'alsa-lib>=1.0.18')
+url="http://www.tux.org/~ricdude/EsounD.html"
+provides=("esd=${pkgver}")
+replaces=('esd')
+conflicts=('esd')
+backup=('etc/esd.conf')
+options=('!libtool')
+source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/0.2/${pkgname}-${pkgver}.tar.bz2
+ esd-0.2.38-alsa-drain.patch
+ esd)
+md5sums=('8d9aad3d94d15e0d59ba9dc0ea990c6c'
+ '3de93efcd1bc196a3585e6aef50eac48'
+ 'a4c76e7c7f75b201ea7ab6fb15b47472')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/esd-0.2.38-alsa-drain.patch" || return 1
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static \
+ --with-audiofile --with-libwrap \
+ --enable-alsa --disable-artstest || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m755 -d "${pkgdir}/etc/rc.d"
+ install -m755 "${srcdir}/esd" "${pkgdir}/etc/rc.d/esd" || return 1
+}
diff --git a/abs/core-testing/esound/esd b/abs/core-testing/esound/esd
new file mode 100755
index 0000000..d90ef55
--- /dev/null
+++ b/abs/core-testing/esound/esd
@@ -0,0 +1,37 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/bin/esd`
+case "$1" in
+ start)
+ stat_busy "Starting Esound Daemon"
+ if [ -z "$PID" ]; then
+ /usr/bin/esd -nobeeps &
+ fi
+ if [ ! -z "$PID" -o $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon esd
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping Esound Daemon"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon esd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
diff --git a/abs/core-testing/esound/esd-0.2.38-alsa-drain.patch b/abs/core-testing/esound/esd-0.2.38-alsa-drain.patch
new file mode 100644
index 0000000..f2fb716
--- /dev/null
+++ b/abs/core-testing/esound/esd-0.2.38-alsa-drain.patch
@@ -0,0 +1,11 @@
+--- esound-0.2.38/audio_alsa09.c.old 2007-06-11 12:22:24.000000000 +0200
++++ esound-0.2.38/audio_alsa09.c 2007-06-11 12:22:49.000000000 +0200
+@@ -486,7 +486,7 @@ void esd_audio_flush(void)
+ }
+
+ if (alsa_playback_handle != NULL)
+- snd_pcm_drain( alsa_playback_handle );
++ snd_pcm_drop( alsa_playback_handle );
+
+ if (alsadbg)
+ print_state();