summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/fbsplash/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-02-12 08:22:14 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-02-12 08:22:14 (GMT)
commit40727c47f4a6319dc101ca97cddd72732db03889 (patch)
treec469bd876c58981ef4abd517af7af7f6c8f8868a /abs/core-testing/fbsplash/PKGBUILD
parentd39d6198243375c7cc8e72aa926d24fc6b625982 (diff)
downloadlinhes_pkgbuild-40727c47f4a6319dc101ca97cddd72732db03889.zip
linhes_pkgbuild-40727c47f4a6319dc101ca97cddd72732db03889.tar.gz
linhes_pkgbuild-40727c47f4a6319dc101ca97cddd72732db03889.tar.bz2
Initial inclusion of fbsplash and deps.
Diffstat (limited to 'abs/core-testing/fbsplash/PKGBUILD')
-rw-r--r--abs/core-testing/fbsplash/PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/abs/core-testing/fbsplash/PKGBUILD b/abs/core-testing/fbsplash/PKGBUILD
new file mode 100644
index 0000000..eec0284
--- /dev/null
+++ b/abs/core-testing/fbsplash/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Greg Helton <gt@fallendusk.org>
+
+pkgname=fbsplash
+pkgver=1.5.4.3
+pkgrel=3
+pkgdesc="A userspace implementation of a splash screen for Linux (formerly known as gensplash)"
+arch=('i686' 'x86_64')
+url="http://fbsplash.berlios.de"
+license=('GPL')
+backup=('etc/conf.d/fbsplash.conf')
+makedepends=('klibc')
+depends=('initscripts' 'miscsplashutils' 'libjpeg' 'libpng' 'freetype2-static' 'gpm' 'libmng')
+conflicts=('bootsplash' 'gensplash')
+install=fbsplash.install
+source=(http://download.berlios.de/fbsplash/splashutils-${pkgver}.tar.bz2 \
+ http://code.thewrecker.net/files/darch.tar.bz2 \
+ fbsplash.inithooks \
+ splash-functions-arch.sh \
+ fbsplash.conf \
+ fbsplash.initcpio_install \
+ fbsplash.daemon)
+md5sums=('c722cd4148817b9c50381d9bdc1ea6ef'
+ '4ea33e99330abf4a9a468ac8c0ba48ca'
+ '44375e92025ce07b3434773efb282127'
+ '8ffb29400a2518b16f3dbca653855268'
+ 'b1b45761b2a5899a4fe8255fc9cfaf9c'
+ '5cce2373181193207d105e150a7f371c'
+ '9f876244d6b09c96cf1543a1b47d6525')
+
+build() {
+ cd ${startdir}/src/splashutils-${pkgver}
+
+ # Configure, make, and install
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-fbcondecor --with-gpm --with-mng --with-png --with-ttf --with-ttf-kernel
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+
+ # Create directories
+ mkdir -p ${startdir}/pkg/lib/splash/cache
+ mkdir -p ${startdir}/pkg/etc/splash
+ mkdir -p ${startdir}/pkg/etc/rc.d/functions.d
+
+ # Install scripts
+ install -D -m644 ${startdir}/src/fbsplash.initcpio_install ${startdir}/pkg/lib/initcpio/install/fbsplash
+ install -D -m644 ${startdir}/src/fbsplash.conf ${startdir}/pkg/etc/conf.d/fbsplash.conf
+ install -D -m744 ${startdir}/src/fbsplash.daemon ${startdir}/pkg/etc/rc.d/fbsplash
+ install -D -m744 ${startdir}/src/splash-functions-arch.sh ${startdir}/pkg/sbin/splash-functions-arch.sh
+
+ # install darch fbsplash theme
+ cp -r ${startdir}/src/darch ${startdir}/pkg/etc/splash/darch
+
+ # install initscripts hooks
+ install -D -m744 ${startdir}/src/fbsplash.inithooks ${startdir}/pkg/etc/rc.d/functions.d/fbsplash.sh
+}