summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/fbsplash/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-04-10 16:45:27 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-04-10 16:45:27 (GMT)
commit7df303b374a3f43a9bf85c4d572c8a2f08ed93e3 (patch)
tree60227df8d0991c40f25063af87d14440437d0b0b /abs/core-testing/fbsplash/PKGBUILD
parent5e80643fcd0df6419f18bccba6594a251eb2d179 (diff)
downloadlinhes_pkgbuild-7df303b374a3f43a9bf85c4d572c8a2f08ed93e3.zip
linhes_pkgbuild-7df303b374a3f43a9bf85c4d572c8a2f08ed93e3.tar.gz
linhes_pkgbuild-7df303b374a3f43a9bf85c4d572c8a2f08ed93e3.tar.bz2
fbsplash: comment out setting up splash.
Added a default value for bootsteps
Diffstat (limited to 'abs/core-testing/fbsplash/PKGBUILD')
-rw-r--r--abs/core-testing/fbsplash/PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/abs/core-testing/fbsplash/PKGBUILD b/abs/core-testing/fbsplash/PKGBUILD
index 9a047d5..5c20232 100644
--- a/abs/core-testing/fbsplash/PKGBUILD
+++ b/abs/core-testing/fbsplash/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=fbsplash
pkgver=1.5.4.3
-pkgrel=8
+pkgrel=12
pkgdesc="A userspace implementation of a splash screen for Linux (formerly known as gensplash)"
arch=('i686' 'x86_64')
url="http://fbsplash.berlios.de"
license=('GPL')
-backup=('etc/conf.d/fbsplash.conf')
+backup=('etc/conf.d/fbsplash.conf' 'etc/conf.d/fbsplash.bootsteps')
makedepends=('klibc')
depends=('initscripts' 'miscsplashutils' 'libjpeg' 'libpng' 'freetype2-static' 'gpm' 'libmng' 'which' 'linhes-splash')
conflicts=('bootsplash' 'gensplash')
@@ -18,15 +18,7 @@ source=(http://download.berlios.de/fbsplash/splashutils-${pkgver}.tar.bz2 \
splash-functions-arch.sh \
fbsplash.conf \
fbsplash.initcpio_install \
- fbsplash.daemon)
-md5sums=('c722cd4148817b9c50381d9bdc1ea6ef'
- '4ea33e99330abf4a9a468ac8c0ba48ca'
- '44375e92025ce07b3434773efb282127'
- '8ffb29400a2518b16f3dbca653855268'
- '82ef6f37c2795db1b4fec0e6f8443c66'
- '21380586a5dafbf7045886ea4374ab65'
- 'bb5154529e4b5fbc701cf4540c15a61a')
-
+ fbsplash.daemon fbsplash.bootsteps)
build() {
cd ${startdir}/src/splashutils-${pkgver}
@@ -46,6 +38,7 @@ build() {
install -D -m644 ${startdir}/src/fbsplash.conf ${startdir}/pkg/etc/conf.d/fbsplash.conf
install -D -m744 ${startdir}/src/fbsplash.daemon ${startdir}/pkg/etc/rc.d/fbsplash
install -D -m744 ${startdir}/src/splash-functions-arch.sh ${startdir}/pkg/sbin/splash-functions-arch.sh
+ install -D -m755 $startdir/src/fbsplash.bootsteps ${startdir}/pkg/etc/conf.d/fbsplash.bootsteps
# install darch fbsplash theme
cp -r ${startdir}/src/darch ${startdir}/pkg/etc/splash/darch
@@ -54,3 +47,10 @@ build() {
install -D -m744 ${startdir}/src/fbsplash.inithooks ${startdir}/pkg/etc/rc.d/functions.d/fbsplash.sh
}
+md5sums=('c722cd4148817b9c50381d9bdc1ea6ef'
+ '4ea33e99330abf4a9a468ac8c0ba48ca'
+ '33b3c7c2050670db0e8b2efd9e088ed9'
+ '8ffb29400a2518b16f3dbca653855268'
+ '82ef6f37c2795db1b4fec0e6f8443c66'
+ '21380586a5dafbf7045886ea4374ab65'
+ 'bb5154529e4b5fbc701cf4540c15a61a')