summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/fbsplash/fbcondecor.daemon
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
commit525753e4a1a139e088d8ac120b19fbab6c0aaaa6 (patch)
tree35cef28abb613da4f58e83f6abbe4bd4cfa244bf /abs/core-testing/fbsplash/fbcondecor.daemon
parent592e3cad43ef12c53f523145d0fd981b54f2a049 (diff)
parentb172f79fadb565ecfbcec9508f9377d8618a4f4c (diff)
downloadlinhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.zip
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.gz
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/fbsplash/fbcondecor.daemon')
-rw-r--r--abs/core-testing/fbsplash/fbcondecor.daemon55
1 files changed, 55 insertions, 0 deletions
diff --git a/abs/core-testing/fbsplash/fbcondecor.daemon b/abs/core-testing/fbsplash/fbcondecor.daemon
new file mode 100644
index 0000000..4d78ea4
--- /dev/null
+++ b/abs/core-testing/fbsplash/fbcondecor.daemon
@@ -0,0 +1,55 @@
+#!/bin/bash
+
+# /etc/rc.d/fbcondecor
+
+# Set FbConDecor backgrounds
+#
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+. /etc/conf.d/fbcondecor
+. /sbin/splash-functions.sh
+
+splash_setup force
+
+retval=0
+[ -z "${SPLASH_TTYS%% }" ] && retval=1
+case "$1"
+in start )
+ if [ "${SPLASH_MODE_REQ}" != "off" ]; then
+ stat_busy "Setting FBconDecor console images"
+ for tty in ${SPLASH_TTYS}; do
+ # avoid blinking on boot
+ [[ "$( fbcondecor_ctl --tty=${tty} -c getstate )" == *\ on ]] && continue
+ fbcondecor_set_theme ${SPLASH_THEME} ${tty} || retval=1
+ done
+ if [ $retval = 0 ]; then
+ stat_done
+ else
+ stat_fail
+ fi
+ fi
+;; stop )
+ stat_busy "Disabling FBconDecor console images"
+ for tty in ${SPLASH_TTYS}; do
+ # avoid errors on restart
+ [[ "$( fbcondecor_ctl --tty=${tty} -c getstate )" == *\ off ]] && continue
+ fbcondecor_ctl --tty=${tty} -c off || retval=1
+ done
+ if [ $retval = 0 ]; then
+ stat_done
+ else
+ stat_fail
+ fi
+;; restart )
+ $0 stop
+ sleep .1
+ echo # don't swallow our status line
+ $0 start
+;; * )
+ echo "usage: $0 {start|stop|restart}"
+esac
+
+exit 0
+
+# EOF #