summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/fbsplash/fbsplash.inithooks
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-06-06 21:08:32 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-06-06 21:08:32 (GMT)
commit1801434dc7e6b34c1fb22a7ece0bad3538a5bb20 (patch)
tree83e3ba0c170833b3afcf5f18d4e94ef100f5afd2 /abs/core-testing/fbsplash/fbsplash.inithooks
parent816aa5eb71f700980ab5cb4c332c74b831d838a8 (diff)
parenta8b2865581cb2db961008c79ea48f31005b20113 (diff)
downloadlinhes_pkgbuild-1801434dc7e6b34c1fb22a7ece0bad3538a5bb20.zip
linhes_pkgbuild-1801434dc7e6b34c1fb22a7ece0bad3538a5bb20.tar.gz
linhes_pkgbuild-1801434dc7e6b34c1fb22a7ece0bad3538a5bb20.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/fbsplash/fbsplash.inithooks')
-rw-r--r--abs/core-testing/fbsplash/fbsplash.inithooks10
1 files changed, 5 insertions, 5 deletions
diff --git a/abs/core-testing/fbsplash/fbsplash.inithooks b/abs/core-testing/fbsplash/fbsplash.inithooks
index 0e8c60c..c396b92 100644
--- a/abs/core-testing/fbsplash/fbsplash.inithooks
+++ b/abs/core-testing/fbsplash/fbsplash.inithooks
@@ -28,14 +28,14 @@ stat_busy() {
# Load variables #
var_load STEP_NR MAX_STEPS RC_MULTI RC_SYSINIT RC_SHUTDOWN
# Only update the splash progress if we're in sysinit, multi, or shutdown. #
- if [[ ${SPLASH_RC_MULTI} == 1 || ${SPLASH_RC_SYSINIT} == 1 || ${SPLASH_RC_SHUTDOWN} == 1 ]]; then
+ if [[ "${SPLASH_RC_MULTI}" == "1" || "${SPLASH_RC_SYSINIT}" == "1" || "${SPLASH_RC_SHUTDOWN}" == "1" ]]; then
((SPLASH_STEP_NR++))
SPLASH_PROGRESS=$((100*${SPLASH_STEP_NR}/${SPLASH_MAX_STEPS}))
SPLASH_CURRENT_PROGRESS=${SPLASH_PROGRESS}
splash_update_progress ${SPLASH_PROGRESS}
var_save STEP_NR CURRENT_PROGRESS
fi
- if [ ${SPLASH_RC_SHUTDOWN} == 1 ]; then
+ if [ "${SPLASH_RC_SHUTDOWN}" == "1" ]; then
save_shutdown_steps
fi
@@ -57,7 +57,7 @@ start_daemon() {
}
# rc.sysinit #
-if [ $CALLER == '/etc/rc.sysinit' ]; then
+if [ "$CALLER" == '/etc/rc.sysinit' ]; then
# echo "fbsplash: Setting up splash..."
splash_cache_prep
SPLASH_MAX_STEPS=$(load_boot_steps)
@@ -69,14 +69,14 @@ if [ $CALLER == '/etc/rc.sysinit' ]; then
fi
# rc.multi #
-if [ $CALLER == '/etc/rc.multi' ]; then
+if [ "$CALLER" == '/etc/rc.multi' ]; then
SPLASH_RC_MULTI=1
SPLASH_RC_SYSINIT=0
var_save RC_MULTI RC_SYSINIT
fi
# rc.shutdown #
-if [ $CALLER == '/etc/rc.shutdown' ]; then
+if [ "$CALLER" == '/etc/rc.shutdown' ]; then
# echo "fbsplash: Setting up splash..."
splash_cache_prep
SPLASH_MAX_STEPS=$(load_shutdown_steps)