summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/fftw2/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core-testing/fftw2/PKGBUILD
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core-testing/fftw2/PKGBUILD')
-rw-r--r--abs/core-testing/fftw2/PKGBUILD56
1 files changed, 0 insertions, 56 deletions
diff --git a/abs/core-testing/fftw2/PKGBUILD b/abs/core-testing/fftw2/PKGBUILD
deleted file mode 100644
index 18aa473..0000000
--- a/abs/core-testing/fftw2/PKGBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: damir <damir@archlinux.org>
-
-pkgname=fftw2
-pkgver=2.1.5
-pkgrel=9
-pkgdesc="FFTW is a C subroutine library for computing the discrete Fourier transform (DFT) in one or more dimensions, of both real and complex data, and of arbitrary input size. This is package is offering backwards compatibility version 2.x.y. of fftw."
-arch=(i686 x86_64)
-url="http://www.fftw.org/"
-license=('GPL2')
-depends=('glibc')
-options=(!libtool !emptydirs !docs)
-source=(http://www.fftw.org/fftw-${pkgver}.tar.gz)
-md5sums=('8d16a84f3ca02a785ef9eb36249ba433')
-
-build() {
- cd ${startdir}/src/fftw-${pkgver}
- # build + install double precision
- ./configure F77=gfortran --prefix=/usr \
- --enable-type-prefix --enable-shared \
- --enable-threads
- make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
-
- make clean
-
- # build + install single precision
- ./configure F77=gfortran --prefix=/usr \
- --enable-float --enable-type-prefix --enable-shared \
- --enable-threads
- make || return 1
- #make prefix=$startdir/pkg/usr install || return 1
- make DESTDIR=${startdir}/pkg install || return 1
- cd $startdir/pkg/usr/include/
- ln -s sfftw.h fftw.h
- ln -s sfftw_threads.h fftw_threads.h
- ln -s srfftw.h rfftw.h
- ln -s srfftw_threads.h rfftw_threads.h
- cd $startdir/pkg/usr/lib
- ln -s libsfftw.a libfftw.a
- ln -s libsfftw.so libfftw.so
- ln -s libsfftw.so.2 libfftw.so.2
- ln -s libsfftw.so.2.0.7 libfftw.so.2.0.7
- ln -s libsfftw_threads.a libfftw_threads.a
- ln -s libsfftw_threads.so libfftw_threads.so
- ln -s libsfftw_threads.so.2 libfftw_threads.so.2
- ln -s libsfftw_threads.so.2.0.7 libfftw_threads.so.2.0.7
- ln -s libsrfftw.a librfftw.a
- ln -s libsrfftw.so librfftw.so
- ln -s libsrfftw.so.2 librfftw.so.2
- ln -s libsrfftw.so.2.0.7 librfftw.so.2.0.7
- ln -s libsrfftw_threads.a librfftw_threads.a
- ln -s libsrfftw_threads.so librfftw_threads.so
- ln -s libsrfftw_threads.so.2 librfftw_threads.so.2
- ln -s libsrfftw_threads.so.2.0.7 librfftw_threads.so.2.0.7
-}