summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/fftwsingle/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
commitc38715641e214272ad7dc6d495edd29940366e7f (patch)
tree9dcd507543e67458d98fa7462f62026041524047 /abs/core-testing/fftwsingle/PKGBUILD
parent3d91b06198a56b6579cb0bd77de65f5908571b87 (diff)
downloadlinhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.zip
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.gz
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.bz2
packages that will be needed in the future.
This is the initial merge of packages from MythVantage that are not MythVantage specific.
Diffstat (limited to 'abs/core-testing/fftwsingle/PKGBUILD')
-rw-r--r--abs/core-testing/fftwsingle/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core-testing/fftwsingle/PKGBUILD b/abs/core-testing/fftwsingle/PKGBUILD
new file mode 100644
index 0000000..c167d3f
--- /dev/null
+++ b/abs/core-testing/fftwsingle/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: ndlarsen <ndlarsen@gmail.com>
+# Comment: Based on PKGBUILDs from the Extra repo for fftw2, maintained by damir <damir@archlinux.org>, and from AUR for fftw2double, maintained by bricem13.
+
+pkgname=fftw2single
+pkgver=2.1.5
+pkgrel=1
+pkgdesc="FFTW is a C subroutine library for computing the discrete Fourier transform (DFT) in one or more dimensions, of both real and complex data, and of arbitrary input size. This is package is offering backwards compatibility version 2.x.y. of fftw."
+arch=('i686')
+license=('GPL')
+url="http://www.fftw.org/"
+depends=('glibc')
+makedepends=('gcc-fortran>=4.1.1')
+source=(http://www.fftw.org/fftw-$pkgver.tar.gz)
+md5sums=('8d16a84f3ca02a785ef9eb36249ba433')
+
+build() {
+
+ cd $startdir/src/fftw-$pkgver
+
+ ./configure F77=gfortran --prefix=/usr \
+ --enable-float --enable-shared \
+ --enable-threads
+ make || return 1
+ make prefix=$startdir/pkg/usr install || return 1
+
+}