summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/gen-init-cpio/Makefile
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core-testing/gen-init-cpio/Makefile
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core-testing/gen-init-cpio/Makefile')
-rw-r--r--abs/core-testing/gen-init-cpio/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/abs/core-testing/gen-init-cpio/Makefile b/abs/core-testing/gen-init-cpio/Makefile
deleted file mode 100644
index 1ebe763..0000000
--- a/abs/core-testing/gen-init-cpio/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-
-DESTDIR =
-PREFIX = /
-
-MKDIR = /bin/mkdir
-INSTALL = /bin/install -c -m 755
-
-CC = /usr/bin/gcc
-LD = /usr/bin/gcc
-
-CFLAGS += -Wall -Wstrict-prototypes -Wsign-compare -Wchar-subscripts \
- -Wpointer-arith -Wcast-align -Wsign-compare
-
-#pretty print!
-E = @echo
-Q = @
-
-all: gen_init_cpio
-.PHONY: all
-.DEFAULT: all
-
-%.o: %.c
- $(E) " compile " $@
- $(Q) $(CC) -c $(CFLAGS) $< -o $@
-
-gen_init_cpio: gen_init_cpio.o
- $(E) ">>build " $@
- $(Q) $(LD) $(LDFLAGS) $@.o -o $@ $(LIB_OBJS)
-
-clean:
- $(E) " clean "
- $(Q) rm -f gen_init_cpio *.o
-.PHONY: clean
-
-install: all
- $(MKDIR) -p $(DESTDIR)$(PREFIX)sbin/
- $(INSTALL) gen_init_cpio $(DESTDIR)$(PREFIX)sbin/
-.PHONY: install
-
-uninstall:
- rm $(DESTDIR)$(PREFIX)sbin/gen_init_cpio
-.PHONY: uninstall