summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/glib/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-12-01 23:48:10 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-12-01 23:48:10 (GMT)
commit575bd0829fce6f7582aefca086e1894b63812ef8 (patch)
tree1b66d798131ebd448034b30a2d7d6111aabf4c52 /abs/core-testing/glib/PKGBUILD
parent466412d4bdf5beb0645eced2d064df5e15f9b76b (diff)
downloadlinhes_pkgbuild-575bd0829fce6f7582aefca086e1894b63812ef8.zip
linhes_pkgbuild-575bd0829fce6f7582aefca086e1894b63812ef8.tar.gz
linhes_pkgbuild-575bd0829fce6f7582aefca086e1894b63812ef8.tar.bz2
Emulators and deps.
Signed-off-by: Cecil Hugh Watson <knoppmyth@gmail.com>
Diffstat (limited to 'abs/core-testing/glib/PKGBUILD')
-rw-r--r--abs/core-testing/glib/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core-testing/glib/PKGBUILD b/abs/core-testing/glib/PKGBUILD
new file mode 100644
index 0000000..0f76a1e
--- /dev/null
+++ b/abs/core-testing/glib/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+
+pkgname=glib
+pkgver=1.2.10
+pkgrel=7
+pkgdesc="Common C routines used by Gtk+ and other libs"
+arch=('i686' 'x86_64')
+url="http://www.gtk.org/"
+license=('LGPL')
+depends=('glibc')
+options=('!libtool')
+source=(ftp://ftp.gtk.org/pub/gtk/v1.2/$pkgname-$pkgver.tar.gz \
+ gcc340.patch \
+ aclocal-fixes.patch)
+md5sums=('6fe30dad87c77b91b632def29dd69ef9' '877b3330e822a4be69a0f8a8c268cfd7'\
+ 'e52c4b88427b9785bb8049dbdc9ff6fb')
+sha1sums=('e5a9361c594608d152d5d9650154c2e3260b87fa'\
+ 'a2cc224a66aeffdcac16ebd9e8af18143cf54918'\
+ 'ae4438cf56c0c9264ee36f6973fb445f9a820be0')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -Np1 -i ../gcc340.patch || return 1
+ patch -Np0 -i ../aclocal-fixes.patch || return 1
+
+ #Arch64 fixes --build/host
+ ./configure --prefix=/usr #--host=i686-pc-linux-gnu
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+}