summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/imagemagick
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-11 18:41:04 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-11 18:41:04 (GMT)
commitbcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7 (patch)
tree1db739b5689e79de25ff05521ff1ef620478df50 /abs/core-testing/imagemagick
parent22cb9c31cde8a125c3b7d159d8b50941cb5c7714 (diff)
downloadlinhes_pkgbuild-bcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7.zip
linhes_pkgbuild-bcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7.tar.gz
linhes_pkgbuild-bcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7.tar.bz2
Updated various packages.
Diffstat (limited to 'abs/core-testing/imagemagick')
-rw-r--r--abs/core-testing/imagemagick/ChangeLog47
-rw-r--r--abs/core-testing/imagemagick/PKGBUILD22
2 files changed, 58 insertions, 11 deletions
diff --git a/abs/core-testing/imagemagick/ChangeLog b/abs/core-testing/imagemagick/ChangeLog
index 8b3a5fb..e46815d 100644
--- a/abs/core-testing/imagemagick/ChangeLog
+++ b/abs/core-testing/imagemagick/ChangeLog
@@ -1,3 +1,50 @@
+2008-12-29 Eric Belanger <eric@archlinux.org>
+
+ * imagemagick 6.4.8.2-1
+ * Upstream update
+
+2008-12-14 Eric Belanger <eric@archlinux.org>
+
+ * imagemagick 6.4.7.8-1
+ * Upstream update
+
+2008-12-05 Eric Belanger <eric@archlinux.org>
+
+ * imagemagick 6.4.7.0-1
+ * Upstream update
+ * Rebuild against heimdal 1.2.1
+
+2008-11-25 Eric Belanger <eric@archlinux.org>
+
+ * imagemagick 6.4.6.3-1
+ * Upstream update
+
+2008-11-14 Eric Belanger <eric@archlinux.org>
+
+ * imagemagick 6.4.5.6-1
+ * Upstream update
+
+2008-10-26 Eric Belanger <eric@archlinux.org>
+
+ * imagemagick 6.4.5.0-1
+ * Upstream update
+
+2008-10-18 Eric Belanger <eric@archlinux.org>
+
+ * imagemagick 6.4.4.9-1
+ * Upstream update
+
+2008-10-03 Eric Belanger <eric@archlinux.org>
+
+ * imagemagick 6.4.4.1-1
+ * Upstream update
+
+2008-09-06 Eric Belanger <eric@archlinux.org>
+
+ * imagemagick 6.4.3.6-1
+ * Upstream update
+ * Added JPEG2000 support (close FS#10544)
+
2008-08-19 Eric Belanger <eric@archlinux.org>
* imagemagick 6.4.2.10-1
diff --git a/abs/core-testing/imagemagick/PKGBUILD b/abs/core-testing/imagemagick/PKGBUILD
index 79555bf..ac04f26 100644
--- a/abs/core-testing/imagemagick/PKGBUILD
+++ b/abs/core-testing/imagemagick/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 9867 2008-08-20 05:56:48Z eric $
+# $Id: PKGBUILD 22960 2008-12-30 05:45:59Z eric $
# Maintainer: Eric Belanger <eric@archlinux.org>
# NOTE: ImageMagick builds against an existing installation
@@ -8,39 +8,39 @@
# install old package, build new package, install new package, rebuild
pkgname=imagemagick
-pkgver=6.4.2.10
+pkgver=6.4.8.2
pkgrel=1
pkgdesc="An image viewing/manipulation program"
arch=('i686' 'x86_64')
url="http://www.imagemagick.org/"
license=('custom')
-depends=('lcms' 'libwmf' 'librsvg' 'libxt' 'gcc-libs' 'ghostscript' 'openexr' 'libtool>=2.2' 'bzip2' 'libxml2')
+depends=('lcms' 'libwmf' 'librsvg' 'libxt' 'gcc-libs' 'ghostscript' 'openexr' 'libtool>=2.2' 'heimdal>=1.2.1' 'bzip2' 'libxml2' 'jasper')
#makedepends=('ghostscript' 'openexr')
options=('!makeflags' '!docs')
source=(ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.bz2 \
libpng_mmx_patch_x86_64.patch add_delegate.patch)
-md5sums=('f60ae313a2cc2fcc980543165e7ebaf4' '069980fc2590c02aed86420996259302'\
+md5sums=('8454e93a0b88fd9319157b5301deff38' '069980fc2590c02aed86420996259302'\
'7f5851c4450b73d52df55c7e806cc316')
-sha1sums=('0c45712a07b0d337ac4130c3ad605566d013ea3f'
+sha1sums=('e5de65c998776c5b49a1b364d05ca3515310e23a'
'e42f3acbe85b6098af75c5cecc9a254baaa0482c'
'19b40dcbc5bf8efb8ce7190fed17e2921de32ea5')
build() {
- cd ${srcdir}/ImageMagick-${pkgver%.*}
+ cd ${srcdir}/ImageMagick-${pkgver%.*}-${pkgver##*.}
if [ "${CARCH}" = "x86_64" ]; then
patch -Np1 < ../libpng_mmx_patch_x86_64.patch || return 1
fi
patch -p0 < ../add_delegate.patch || return 1
+ sed -i "s/with_autotrace='no'/with_autotrace='yes'/" configure || return 1
- #LIBS=-lMagickWand ./configure --prefix=/usr --without-modules --disable-static --disable-openmp \
- ./configure --prefix=/usr --without-modules --disable-static --disable-openmp \
- --with-x --with-wmf --with-openexr \
+ LIBS=-lMagickWand ./configure --prefix=/usr --without-modules --disable-static --enable-openmp \
+ --with-x --with-wmf --with-openexr --with-xml \
--with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
--with-perl --with-perl-options="INSTALLDIRS=vendor" \
- --without-gvc --without-djvu --without-jp2 \
- --without-fpx --without-dps || return 1
+ --without-gvc --without-djvu --with-jp2 \
+ --without-jbig --without-fpx --without-dps || return 1
make || return 1
make DESTDIR=${pkgdir} install || return 1