summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/klibc-module-init-tools
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-26 06:30:59 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-26 06:30:59 (GMT)
commit22717178ce9fdec1b5711bcaea5a39e2334d94b1 (patch)
tree11ef6ca700440089dedccad0ea1637213effc3b4 /abs/core-testing/klibc-module-init-tools
parente4b0f387e05bf4ff0df15885a69c5e704ece612f (diff)
downloadlinhes_pkgbuild-22717178ce9fdec1b5711bcaea5a39e2334d94b1.zip
linhes_pkgbuild-22717178ce9fdec1b5711bcaea5a39e2334d94b1.tar.gz
linhes_pkgbuild-22717178ce9fdec1b5711bcaea5a39e2334d94b1.tar.bz2
Needed to installed newer kernel.
Diffstat (limited to 'abs/core-testing/klibc-module-init-tools')
-rw-r--r--abs/core-testing/klibc-module-init-tools/PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/abs/core-testing/klibc-module-init-tools/PKGBUILD b/abs/core-testing/klibc-module-init-tools/PKGBUILD
index 80a1ede..8b4ee8a 100644
--- a/abs/core-testing/klibc-module-init-tools/PKGBUILD
+++ b/abs/core-testing/klibc-module-init-tools/PKGBUILD
@@ -1,29 +1,23 @@
-# $Id: PKGBUILD 5989 2008-07-22 12:58:46Z thomas $
+# $Id: PKGBUILD 23617 2009-01-11 14:11:13Z thomas $
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgname=klibc-module-init-tools
-pkgver=3.4
-pkgrel=10
+pkgver=3.5
+pkgrel=1
pkgdesc="Utilities for inserting and removing modules from the Linux kernel"
arch=(i686 x86_64)
url="http://www.kernel.org"
license=('GPL')
groups=('base')
depends=('klibc' $(basename /lib/klibc-*.so .so))
-source=(http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-$pkgver.tar.bz2 \
- makefile.patch
- fix-modprobe-ignore-path.patch)
-md5sums=('db6ac059e80e8dd4389dbe81ee61f3c6'
- 'c48553c2b61fd8d9784aa86e559b9d7b'
- '335c3f8317f257ddd70b09271b4360bd')
+source=(http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-$pkgver.tar.bz2)
+md5sums=('2b47686247fc9a99bfdb9dd1d1d80e6f')
build() {
cd $startdir/src/module-init-tools-$pkgver
- patch -p1 -i ../makefile.patch || return 1
- autoreconf || return 1
- patch -p0 -i ../fix-modprobe-ignore-path.patch || return 1
- sed -i 's|/usr/bin/install|/bin/install|g' install-with-care
CFLAGS="${CFLAGS} -DCONFIG_NO_BACKWARDS_COMPAT" CC=klcc LD=klcc ./configure --prefix=/usr/lib/klibc
+ # klibc lacks getc_unlocked, so use getc instead
+ sed 's|getc_unlocked|getc|g' -i *.c
make || return 1
INSTALL=/bin/install make DESTDIR=$startdir/pkg install || return 1
rm -f $startdir/pkg/usr/lib/klibc/sbin/{generate-modprobe.conf,insmod.static}