summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libcaca/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-14 18:38:20 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-14 18:38:20 (GMT)
commit75a974500de1bb4b0bb84b726a9d7075d07e18b7 (patch)
tree9a0c45226e4b04a8595fbacfcde115d444f5c5d5 /abs/core-testing/libcaca/PKGBUILD
parent14beb839185f027cba412b6aa0941296a843818b (diff)
downloadlinhes_pkgbuild-75a974500de1bb4b0bb84b726a9d7075d07e18b7.zip
linhes_pkgbuild-75a974500de1bb4b0bb84b726a9d7075d07e18b7.tar.gz
linhes_pkgbuild-75a974500de1bb4b0bb84b726a9d7075d07e18b7.tar.bz2
Removing more cross repo makedepends.
Moved the following packages from extra->core. nasm automake autoconf sharutils imake gperf/ yasm/ setuptools/ libcaca/ libdca/ live-media/ There are still several cross repo make depends, but some packages just dont' belong in core. For instance avahi and ca-certificates(core) depend on mono and ruby(extra). But really mono and ruby do not belong in core.
Diffstat (limited to 'abs/core-testing/libcaca/PKGBUILD')
-rw-r--r--abs/core-testing/libcaca/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/abs/core-testing/libcaca/PKGBUILD b/abs/core-testing/libcaca/PKGBUILD
new file mode 100644
index 0000000..f0c3710
--- /dev/null
+++ b/abs/core-testing/libcaca/PKGBUILD
@@ -0,0 +1,20 @@
+# $Id: PKGBUILD 9776 2008-08-19 00:46:51Z eric $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libcaca
+pkgver=0.9
+pkgrel=2
+pkgdesc="Color AsCii Art library"
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://libcaca.zoy.org/"
+depends=('freetype2' 'imlib2' 'ncurses>=5.6-7')
+source=(http://libcaca.zoy.org/files/libcaca/${pkgname}-${pkgver}.tar.gz)
+md5sums=('97b0f526f39491389e159055f574c921')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --mandir=/usr/share/man --enable-shared --disable-doc
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+}