summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libdca/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-14 18:38:20 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-14 18:38:20 (GMT)
commit75a974500de1bb4b0bb84b726a9d7075d07e18b7 (patch)
tree9a0c45226e4b04a8595fbacfcde115d444f5c5d5 /abs/core-testing/libdca/PKGBUILD
parent14beb839185f027cba412b6aa0941296a843818b (diff)
downloadlinhes_pkgbuild-75a974500de1bb4b0bb84b726a9d7075d07e18b7.zip
linhes_pkgbuild-75a974500de1bb4b0bb84b726a9d7075d07e18b7.tar.gz
linhes_pkgbuild-75a974500de1bb4b0bb84b726a9d7075d07e18b7.tar.bz2
Removing more cross repo makedepends.
Moved the following packages from extra->core. nasm automake autoconf sharutils imake gperf/ yasm/ setuptools/ libcaca/ libdca/ live-media/ There are still several cross repo make depends, but some packages just dont' belong in core. For instance avahi and ca-certificates(core) depend on mono and ruby(extra). But really mono and ruby do not belong in core.
Diffstat (limited to 'abs/core-testing/libdca/PKGBUILD')
-rw-r--r--abs/core-testing/libdca/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/abs/core-testing/libdca/PKGBUILD b/abs/core-testing/libdca/PKGBUILD
new file mode 100644
index 0000000..4794c02
--- /dev/null
+++ b/abs/core-testing/libdca/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=libdca
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="Free library for decoding DTS Coherent Acoustics streams"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://www.videolan.org/developers/libdca.html"
+source=(http://download.videolan.org/pub/videolan/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2)
+md5sums=('dab6b2795c66a82a6fcd4f8343343021')
+provides=('libdts')
+replaces=('libdts')
+options=('!libtool' '!emptydirs')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+}