summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libdownload
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core-testing/libdownload
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core-testing/libdownload')
-rw-r--r--abs/core-testing/libdownload/PKGBUILD21
-rw-r--r--abs/core-testing/libdownload/largefiles.patch12
2 files changed, 33 insertions, 0 deletions
diff --git a/abs/core-testing/libdownload/PKGBUILD b/abs/core-testing/libdownload/PKGBUILD
new file mode 100644
index 0000000..7685097
--- /dev/null
+++ b/abs/core-testing/libdownload/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 2480 2008-06-03 15:53:46Z aaron $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+
+pkgname=libdownload
+pkgver=1.3
+pkgrel=10
+pkgdesc="URL based download library, forked from libfetch"
+arch=('i686' 'x86_64')
+license=('BSD')
+groups=('base')
+depends=('glibc')
+url="http://code.phraktured.net/?p=libdownload.git"
+source=(http://code.phraktured.net/source/$pkgname-$pkgver.tar.gz)
+md5sums=('77e10293fd4262745110eb423a10490c')
+
+build() {
+ cd $startdir/src/${pkgname}-${pkgver}
+ [ "$CARCH" = "x86_64" ] && sed -i -e "s/-O2\ -pipe/-O2\ -pipe\ \-fPIC/g" Makefile
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+}
diff --git a/abs/core-testing/libdownload/largefiles.patch b/abs/core-testing/libdownload/largefiles.patch
new file mode 100644
index 0000000..7b10a4c
--- /dev/null
+++ b/abs/core-testing/libdownload/largefiles.patch
@@ -0,0 +1,12 @@
+diff -u libdownload-1.1/Makefile libdownload-1.1-new/Makefile
+--- libdownload-1.1/Makefile 2006-11-17 10:19:53.000000000 -0500
++++ libdownload-1.1-new/Makefile 2007-08-17 19:53:21.000000000 -0400
+@@ -3,7 +3,7 @@
+ DEBUG = true
+ ENABLE_HTTPS = true
+
+-CFLAGS = -O2 -pipe -I. -DINET6 -D_GNU_SOURCE
++CFLAGS = -O2 -pipe -I. -DINET6 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ WARNINGS = -Wall -Wstrict-prototypes -Wsign-compare -Wchar-subscripts \
+ -Wpointer-arith -Wcast-align -Wsign-compare
+ CFLAGS += $(WARNINGS)