summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libpng/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core-testing/libpng/PKGBUILD
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core-testing/libpng/PKGBUILD')
-rw-r--r--abs/core-testing/libpng/PKGBUILD42
1 files changed, 0 insertions, 42 deletions
diff --git a/abs/core-testing/libpng/PKGBUILD b/abs/core-testing/libpng/PKGBUILD
deleted file mode 100644
index d665f3f..0000000
--- a/abs/core-testing/libpng/PKGBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# $Id: PKGBUILD 84179 2010-06-27 07:28:57Z pierre $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-# Contributor: dorphell <dorphell@archlinux.org>
-# Contributor: Travis Willard <travis@archlinux.org>
-# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
-
-pkgname=libpng
-pkgver=1.4.3
-_apngver=1.4.2
-pkgrel=1
-pkgdesc="A collection of routines used to create PNG format graphics files"
-arch=('i686' 'x86_64')
-url="http://www.libpng.org/pub/png/libpng.html"
-license=('custom')
-depends=('zlib')
-options=('!libtool')
-source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.xz"
- "http://downloads.sourceforge.net/sourceforge/libpng-apng/libpng-${_apngver}-apng.patch.gz")
-md5sums=('322e2e0c0dea7a374ce6e60d9a72e604'
- '378ade7c68c25d00e099b28911d06561')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- # Add animated PNG (apng) support
- # see http://sourceforge.net/projects/libpng-apng/
- patch -p1 -i "${srcdir}/libpng-${_apngver}-apng.patch"
-
- libtoolize --force --copy
- aclocal
- autoconf
- automake --add-missing
-
- ./configure --prefix=/usr
- make
- make DESTDIR="${pkgdir}" install
-
- cd contrib/pngminus
- make PNGLIB="-L${pkgdir}/usr/lib -lpng" -f makefile.std png2pnm pnm2png
- install -m755 png2pnm pnm2png "${pkgdir}/usr/bin/"
- install -D -m644 ../../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}