summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libvdpau/PKGBUILD
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-12-02 15:18:28 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-12-02 15:18:28 (GMT)
commitbc28357575b5f1a3fca4c29a592c1124577be883 (patch)
tree8b3cfd1f7800c5b4b3e730bdd0c73aa85fdb5a0c /abs/core-testing/libvdpau/PKGBUILD
parent95a2256350592fe7255a2ba0ee5c670d72be75b8 (diff)
downloadlinhes_pkgbuild-bc28357575b5f1a3fca4c29a592c1124577be883.zip
linhes_pkgbuild-bc28357575b5f1a3fca4c29a592c1124577be883.tar.gz
linhes_pkgbuild-bc28357575b5f1a3fca4c29a592c1124577be883.tar.bz2
libvdpau: nVidia vdpau library (first cut)
Diffstat (limited to 'abs/core-testing/libvdpau/PKGBUILD')
-rw-r--r--abs/core-testing/libvdpau/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/core-testing/libvdpau/PKGBUILD b/abs/core-testing/libvdpau/PKGBUILD
new file mode 100644
index 0000000..11d4674
--- /dev/null
+++ b/abs/core-testing/libvdpau/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libvdpau
+pkgver=0.3
+pkgrel=2
+pkgdesc="Nvidia VDPAU library"
+arch=(i686 x86_64)
+url=http://cgit.freedesktop.org/~aplattner/libvdpau
+depends=('gcc-libs>=4.3.3')
+conflicts=('nvidia-utils<190.42-2')
+options=('!libtool' 'force')
+license=('custom')
+source=(http://people.freedesktop.org/~aplattner/vdpau/${pkgname}-${pkgver}.tar.gz)
+sha1sums=('e32980329c84dbb90e2954e4a38051618f053ef7')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
+}