summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libvisual-plugins/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-14 04:14:54 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-14 04:14:54 (GMT)
commitee7d8d75c14ed0ae36cc0e34ae150012c97e197d (patch)
tree46556f5e4898da764cc831aa760d908c2ccc9961 /abs/core-testing/libvisual-plugins/PKGBUILD
parentc2941a012cbea19073e72af561b37a1255a1fe6c (diff)
downloadlinhes_pkgbuild-ee7d8d75c14ed0ae36cc0e34ae150012c97e197d.zip
linhes_pkgbuild-ee7d8d75c14ed0ae36cc0e34ae150012c97e197d.tar.gz
linhes_pkgbuild-ee7d8d75c14ed0ae36cc0e34ae150012c97e197d.tar.bz2
Moving mjpeg , libvisual* and transcode to core.
There are pkg's in core that depend on them.
Diffstat (limited to 'abs/core-testing/libvisual-plugins/PKGBUILD')
-rw-r--r--abs/core-testing/libvisual-plugins/PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/abs/core-testing/libvisual-plugins/PKGBUILD b/abs/core-testing/libvisual-plugins/PKGBUILD
new file mode 100644
index 0000000..6324fba
--- /dev/null
+++ b/abs/core-testing/libvisual-plugins/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: damir <damir@archlinux.org>
+
+pkgname=libvisual-plugins
+pkgver=0.4.0
+pkgrel=5
+pkgdesc="plugins for libvisual"
+arch=("i686" "x86_64")
+license=('GPL')
+url="http://www.localhost.nl/~synap/libvisual/"
+depends=('libvisual>=0.4.0' 'gtk2' 'mesa' 'alsa-lib' 'esd' 'jack-audio-connection-kit')
+makedepends=(pkgconfig)
+install=libvisual-plugins.install
+source=("http://downloads.sourceforge.net/sourceforge/libvisual/libvisual-plugins-${pkgver}.tar.gz"
+ '01_disable-gforce-dfsg.patch'
+ '02_64-bit_JESS_fix.patch'
+ '03_build_against_gl_fixes.patch'
+ '04_lv_analyzer_build_fix.patch'
+ '05_fix_po.patch'
+ '60_no-const-vispluginfo-in-nastyfft.patch'
+ '90_autoreconf.patch')
+md5sums=('4330e9287f9d6fae02f482f428a1e77b'
+ '600969a691372c8894c90765de84f732'
+ 'f9cfb607bfcbfef60830fae4e7dc6963'
+ '116701408747dbb87dc134434478ebe2'
+ '01678a8f1584c76a44e59d81003a1109'
+ '6189b7427c4e11c8b8d6c6266d6a1629'
+ '7012518727cb072a7e90a826a5577cc6'
+ '4aa3ffc17dcb4d25129f483b1842fac9')
+options=(!libtool)
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+# patch -p1 < ../01_disable-gforce-dfsg.patch
+# patch -p1 < ../02_64-bit_JESS_fix.patch
+# patch -p1 < ../03_build_against_gl_fixes.patch
+# patch -p1 < ../04_lv_analyzer_build_fix.patch
+# patch -p1 < ../05_fix_po.patch
+# patch -p1 < ../60_no-const-vispluginfo-in-nastyfft.patch
+# patch -p1 < ../90_autoreconf.patch
+ ./configure --prefix=/usr --enable-alsa --disable-gstreamer-plugin
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+}