summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libx11/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
commit525753e4a1a139e088d8ac120b19fbab6c0aaaa6 (patch)
tree35cef28abb613da4f58e83f6abbe4bd4cfa244bf /abs/core-testing/libx11/PKGBUILD
parent592e3cad43ef12c53f523145d0fd981b54f2a049 (diff)
parentb172f79fadb565ecfbcec9508f9377d8618a4f4c (diff)
downloadlinhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.zip
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.gz
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/libx11/PKGBUILD')
-rw-r--r--abs/core-testing/libx11/PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/abs/core-testing/libx11/PKGBUILD b/abs/core-testing/libx11/PKGBUILD
index cfcc85a..2261d79 100644
--- a/abs/core-testing/libx11/PKGBUILD
+++ b/abs/core-testing/libx11/PKGBUILD
@@ -1,31 +1,31 @@
-# $Id: PKGBUILD 34217 2009-04-08 08:01:42Z jgc $
-# Maintainer: Alexander Baldeck <alexander@archlinux.org>
-# Contributor Jan de Groot <jgc@archlinux.org>
+# $Id: PKGBUILD 81970 2010-06-07 13:27:07Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
pkgname=libx11
-pkgver=1.2.1
+pkgver=1.3.4
pkgrel=1
pkgdesc="X11 client-side library"
arch=(i686 x86_64)
url="http://xorg.freedesktop.org/"
-depends=('libxcb>=1.2' 'kbproto>=1.0.3')
-makedepends=('xproto>=7.0.14' 'xextproto>=7.0.5' 'xf86bigfontproto>=1.1.2' 'xtrans>=1.2.3' 'kbproto>=1.0.3' 'inputproto>=1.5.0' 'xorg-util-macros>=1.2.1')
+depends=('libxcb>=1.6' 'kbproto>=1.0.4')
+makedepends=('xproto>=7.0.17' 'xextproto>=7.1.1' 'xf86bigfontproto>=1.2.0' 'xtrans>=1.2.5' 'inputproto>=2.0' 'xorg-util-macros>=1.8.0')
options=('!libtool')
license=('custom:XFREE86')
source=(${url}/releases/individual/lib/libX11-${pkgver}.tar.bz2
- xorg.sh)
-md5sums=('2f2beb98e71f397e1209beaca4e97cb1'
- '942ff006e69e041f0307c1316e0dec5d')
+ xorg.sh)
+sha1sums=('5aab6dc8ed5ec0e86419626715efc3edd34d1db4'
+ 'b59214fe7d1d213f86b074a677eb624e52142ad7')
build() {
cd "${srcdir}/libX11-${pkgver}"
./configure --prefix=/usr \
- --with-xcb || return 1
+ --with-xcb --disable-static || return 1
make || return 1
+ make check || return 1
make DESTDIR="${pkgdir}" install || return 1
install -m755 -d "${pkgdir}/etc/profile.d"
- install -m755 "${srcdir}/xorg.sh" \
- "${pkgdir}/etc/profile.d/" || return 1
+ install -m755 "${srcdir}/xorg.sh" "${pkgdir}/etc/profile.d/" || return 1
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1