summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libx11/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-05-01 00:03:41 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-05-01 00:03:41 (GMT)
commit757c7a6f82a45da2a43bbc2dd5843fce81e1469e (patch)
treef70ac1e5d4a69d3b4fe2034832975e4a25338293 /abs/core-testing/libx11/PKGBUILD
parent06546852a0d981fda8611eb3adf48e0afeac3947 (diff)
downloadlinhes_pkgbuild-757c7a6f82a45da2a43bbc2dd5843fce81e1469e.zip
linhes_pkgbuild-757c7a6f82a45da2a43bbc2dd5843fce81e1469e.tar.gz
linhes_pkgbuild-757c7a6f82a45da2a43bbc2dd5843fce81e1469e.tar.bz2
Latest versions.
Diffstat (limited to 'abs/core-testing/libx11/PKGBUILD')
-rw-r--r--abs/core-testing/libx11/PKGBUILD35
1 files changed, 13 insertions, 22 deletions
diff --git a/abs/core-testing/libx11/PKGBUILD b/abs/core-testing/libx11/PKGBUILD
index d697a21..cfcc85a 100644
--- a/abs/core-testing/libx11/PKGBUILD
+++ b/abs/core-testing/libx11/PKGBUILD
@@ -1,41 +1,32 @@
-# $Id: PKGBUILD 20482 2008-12-05 09:43:28Z jgc $
+# $Id: PKGBUILD 34217 2009-04-08 08:01:42Z jgc $
# Maintainer: Alexander Baldeck <alexander@archlinux.org>
# Contributor Jan de Groot <jgc@archlinux.org>
pkgname=libx11
-pkgver=1.1.5
-pkgrel=2
+pkgver=1.2.1
+pkgrel=1
pkgdesc="X11 client-side library"
arch=(i686 x86_64)
url="http://xorg.freedesktop.org/"
-depends=('libxcb>=1.1.90.1' 'kbproto>=1.0.3')
-makedepends=('xproto>=7.0.13' 'xextproto>=7.0.3' 'xf86bigfontproto>=1.1.2' 'xtrans>=1.2.1' 'kbproto>=1.0.3' 'inputproto>=1.4.4' 'xorg-util-macros')
+depends=('libxcb>=1.2' 'kbproto>=1.0.3')
+makedepends=('xproto>=7.0.14' 'xextproto>=7.0.5' 'xf86bigfontproto>=1.1.2' 'xtrans>=1.2.3' 'kbproto>=1.0.3' 'inputproto>=1.5.0' 'xorg-util-macros>=1.2.1')
options=('!libtool')
license=('custom:XFREE86')
source=(${url}/releases/individual/lib/libX11-${pkgver}.tar.bz2
- 012_ru_RU_UTF-8_XLC_LOCALE.diff
xorg.sh)
-md5sums=('d1512d65dadd4f48c779d4749e7753a8'
- 'c7e38a68b932ed557bc71979eed2a8a1'
+md5sums=('2f2beb98e71f397e1209beaca4e97cb1'
'942ff006e69e041f0307c1316e0dec5d')
build() {
- cd ${srcdir}/libX11-${pkgver}
- patch -Np1 -i ${srcdir}/012_ru_RU_UTF-8_XLC_LOCALE.diff || return 1
-
- libtoolize --force --copy || return 1
- aclocal || return 1
- autoconf || return 1
- automake --add-missing || return 1
-
+ cd "${srcdir}/libX11-${pkgver}"
./configure --prefix=/usr \
--with-xcb || return 1
make || return 1
- make DESTDIR=${pkgdir} install || return 1
+ make DESTDIR="${pkgdir}" install || return 1
- install -m755 -d ${pkgdir}/etc/profile.d
- install -m755 ${srcdir}/xorg.sh \
- ${pkgdir}/etc/profile.d/ || return 1
+ install -m755 -d "${pkgdir}/etc/profile.d"
+ install -m755 "${srcdir}/xorg.sh" \
+ "${pkgdir}/etc/profile.d/" || return 1
- install -d -m755 ${pkgdir}/usr/share/licenses/${pkgname}
- install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
}