summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libxcb/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-05-02 00:49:58 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-05-02 00:49:58 (GMT)
commit1f70585d4abb80a2cc47316ab2b4851637939997 (patch)
tree4435740ad96c057ee9dce9458b9c56bf6ce0c73c /abs/core-testing/libxcb/PKGBUILD
parent3a0c305fe94bf308401db48db087b81d88231bfa (diff)
downloadlinhes_pkgbuild-1f70585d4abb80a2cc47316ab2b4851637939997.zip
linhes_pkgbuild-1f70585d4abb80a2cc47316ab2b4851637939997.tar.gz
linhes_pkgbuild-1f70585d4abb80a2cc47316ab2b4851637939997.tar.bz2
Latest versions.
Diffstat (limited to 'abs/core-testing/libxcb/PKGBUILD')
-rw-r--r--abs/core-testing/libxcb/PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/abs/core-testing/libxcb/PKGBUILD b/abs/core-testing/libxcb/PKGBUILD
index c61df23..59982e9 100644
--- a/abs/core-testing/libxcb/PKGBUILD
+++ b/abs/core-testing/libxcb/PKGBUILD
@@ -1,34 +1,32 @@
-# $Id: PKGBUILD 8004 2008-08-05 18:11:40Z jgc $
+# $Id: PKGBUILD 27498 2009-02-22 09:23:59Z andyrtr $
# Maintainer: Alexander Baldeck <alexander@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=libxcb
-pkgver=1.1.90.1
+pkgver=1.2
pkgrel=1
pkgdesc="X11 client-side library"
arch=(i686 x86_64)
url="http://xcb.freedesktop.org/"
-depends=('xcb-proto>=1.2' 'libxdmcp' 'libxau')
+depends=('xcb-proto>=1.4' 'libxdmcp' 'libxau')
makedepends=('pkgconfig' 'libxslt' 'python')
+conflicts=('libx11<1.1.99.2')
options=('!libtool')
license=('custom')
source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2
- libxcb-1.1-no-pthread-stubs.patch
- libxcb-1.1-sloppy-lock.patch)
-md5sums=('c4b67c5576ed58e2fd4a2855c0b21aa6'
- 'a53f09ab3ec5cbfc1b0848bd137c535a'
- '4b3fbedc471d7ab336a18f1d0f853ddd')
+ libxcb-1.1-no-pthread-stubs.patch)
+md5sums=('ae32b7846a7d83f5ec542a5431117564'
+ 'a53f09ab3ec5cbfc1b0848bd137c535a')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- patch -Np1 -i ${srcdir}/libxcb-1.1-no-pthread-stubs.patch || return 1
- patch -Np1 -i ${srcdir}/libxcb-1.1-sloppy-lock.patch || return 1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/libxcb-1.1-no-pthread-stubs.patch" || return 1
libtoolize --force --copy || return 1
aclocal || return 1
autoconf || return 1
automake --add-missing || return 1
./configure --prefix=/usr --enable-xinput || return 1
make || return 1
- make DESTDIR=${pkgdir} install || return 1
- install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
- install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
}