summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/lighttpd
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-03-14 23:33:06 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-03-14 23:33:06 (GMT)
commit3d7c59c43f41cf1a9a13831c287373211e089a02 (patch)
tree11a275eef5b1c8903d857aa3aafadbe11c8cfe58 /abs/core-testing/lighttpd
parent455c204dc578377cdf662575d1cb9667d0f77137 (diff)
downloadlinhes_pkgbuild-3d7c59c43f41cf1a9a13831c287373211e089a02.zip
linhes_pkgbuild-3d7c59c43f41cf1a9a13831c287373211e089a02.tar.gz
linhes_pkgbuild-3d7c59c43f41cf1a9a13831c287373211e089a02.tar.bz2
lighttpd: add sed statement to post-install.
This should update any old versions rename changelog
Diffstat (limited to 'abs/core-testing/lighttpd')
-rw-r--r--abs/core-testing/lighttpd/PKGBUILD4
-rw-r--r--abs/core-testing/lighttpd/__changelog (renamed from abs/core-testing/lighttpd/_changelog)0
-rwxr-xr-x[-rw-r--r--]abs/core-testing/lighttpd/lighttpd.install1
3 files changed, 3 insertions, 2 deletions
diff --git a/abs/core-testing/lighttpd/PKGBUILD b/abs/core-testing/lighttpd/PKGBUILD
index 3695f0f..cec41d4 100644
--- a/abs/core-testing/lighttpd/PKGBUILD
+++ b/abs/core-testing/lighttpd/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lighttpd
pkgver=1.4.26
-pkgrel=3
+pkgrel=7
pkgdesc='a secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
@@ -21,7 +21,7 @@ options=('!libtool' 'emptydirs')
source=("http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${pkgver}.tar.bz2" \
'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' 'auth-inc.conf' \
'openssl-0.9.8m.patch')
-
+install='lighttpd.install'
build() {
cd $srcdir/$pkgname-$pkgver
diff --git a/abs/core-testing/lighttpd/_changelog b/abs/core-testing/lighttpd/__changelog
index a96d942..a96d942 100644
--- a/abs/core-testing/lighttpd/_changelog
+++ b/abs/core-testing/lighttpd/__changelog
diff --git a/abs/core-testing/lighttpd/lighttpd.install b/abs/core-testing/lighttpd/lighttpd.install
index bf4c132..0e32a66 100644..100755
--- a/abs/core-testing/lighttpd/lighttpd.install
+++ b/abs/core-testing/lighttpd/lighttpd.install
@@ -2,5 +2,6 @@ pre_upgrade() {
mv /etc/lighttpd/lighttpd.conf /etc/lighttpd/lighttpd.conf.old
}
post_upgrade() {
+ sed -i 's|"^/mythweb|"/{1,2}mythweb|g' /etc/lighttpd/lighttpd.conf
touch /etc/lighttpd/lighttpd.user
}