summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/lighttpd
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-10-23 01:40:37 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-10-23 01:40:37 (GMT)
commit7f24a313f0815854ff88a0e33a066a73de4f3be1 (patch)
tree63f1de317bd6d4d3b283939c3481c3ed3e4e71f9 /abs/core-testing/lighttpd
parentde2ffe85032410437eb7dabdec63031e908fd43c (diff)
downloadlinhes_pkgbuild-7f24a313f0815854ff88a0e33a066a73de4f3be1.zip
linhes_pkgbuild-7f24a313f0815854ff88a0e33a066a73de4f3be1.tar.gz
linhes_pkgbuild-7f24a313f0815854ff88a0e33a066a73de4f3be1.tar.bz2
initial checkin of lighttpd and supporting libs.
Also included is a new package callede local-website. This package contains the contents of http://localhost that runs on every LinHES box. The initial checkin is taken from R5.5
Diffstat (limited to 'abs/core-testing/lighttpd')
-rw-r--r--abs/core-testing/lighttpd/PKGBUILD71
-rw-r--r--abs/core-testing/lighttpd/lighttpd.install16
-rw-r--r--abs/core-testing/lighttpd/lighttpd.logrotate.d5
-rw-r--r--abs/core-testing/lighttpd/lighttpd.rc.d38
4 files changed, 130 insertions, 0 deletions
diff --git a/abs/core-testing/lighttpd/PKGBUILD b/abs/core-testing/lighttpd/PKGBUILD
new file mode 100644
index 0000000..2c0132b
--- /dev/null
+++ b/abs/core-testing/lighttpd/PKGBUILD
@@ -0,0 +1,71 @@
+# $Id: PKGBUILD 13948 2008-09-30 12:03:07Z douglas $
+# Maintainer: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=lighttpd
+pkgver=1.4.20
+pkgrel=1
+pkgdesc='a secure, fast, compliant and very flexible web-server'
+license=('custom')
+arch=('i686' 'x86_64')
+url="http://www.lighttpd.net/"
+#depends=('pcre' 'openssl' 'zlib' 'bzip2' 'attr' 'libldap')
+depends=('pcre' 'openssl' 'zlib' 'bzip2' 'attr' )
+makedepends=('fcgi' 'libmysqlclient' 'libxml2' 'e2fsprogs' 'sqlite3' 'gdbm' 'pkgconfig')
+optdepends=('libxml2: mod_webdav' \
+ 'e2fsprogs: mod_webdav' \
+ 'lua: mod_cml/mod_magnet' \
+ 'libmysqlclient: mod_mysql_vhost' \
+ 'sqlite3: mod_webdav' \
+ 'gdbm: mod_trigger_b4_dl' \
+ )
+backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd')
+options=('!libtool' 'emptydirs')
+install='lighttpd.install'
+source=("http://www.lighttpd.net/download/lighttpd-${pkgver}.tar.bz2" \
+ 'lighttpd.rc.d' 'lighttpd.logrotate.d')
+
+md5sums=('ed6ee0bb714f393219a32768d86984d8'
+ 'bd690eee0d9e51857448770a151023b0'
+ '857e174643fd7761a2f0d8431a679f6c')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib/lighttpd/modules \
+ --sysconfdir=/etc/lighttpd \
+ --sharedstatedir=/usr/var \
+ --localstatedir=/var \
+ --libdir=/usr/lib/lighttpd \
+ --includedir=/usr/include/lighttpd \
+ --with-mysql --without-sqlite3 \
+ --without-ldap \
+ --with-attr \
+ --with-openssl \
+ --with-kerberos5 \
+ --without-fam \
+ --with-webdav-props \
+ --with-webdav-locks \
+ --with-gdbm \
+ --with-memcache \
+ --without-lua || return 1
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+
+ install -D -m755 ../lighttpd.rc.d $pkgdir/etc/rc.d/lighttpd
+ install -D -m644 ../lighttpd.logrotate.d $pkgdir/etc/logrotate.d/lighttpd
+ install -d -m755 $pkgdir/var/run/lighttpd/
+ install -d -m755 -o http -g http $pkgdir/var/log/lighttpd/
+
+ install -D -m644 doc/lighttpd.conf $pkgdir/etc/lighttpd/lighttpd.conf
+
+ # set sane defaults
+ sed -e 's|/srv/www/htdocs/|/srv/http/|' \
+ -e 's|/srv/www/|/srv/http/|' \
+ -e 's|#server.username = "wwwrun"|server.username = "http"|' \
+ -e 's|#server.groupname = "wwwrun"|server.groupname = "http"|' \
+ -e 's|#server.pid-file = "/var/run/lighttpd.pid"|server.pid-file = "/var/run/lighttpd/lighttpd.pid"|' \
+ -e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
+ -i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
+
+ install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+}
diff --git a/abs/core-testing/lighttpd/lighttpd.install b/abs/core-testing/lighttpd/lighttpd.install
new file mode 100644
index 0000000..9d98d41
--- /dev/null
+++ b/abs/core-testing/lighttpd/lighttpd.install
@@ -0,0 +1,16 @@
+post_upgrade() {
+ if [ $(vercmp '1.4.19-1' $2) -ge 0 ]; then
+ echo '
+ ==> New default DocumentRoot
+
+ lighttpd uses /srv/http as default DocumentRoot.
+ You can still use your current DocumentRoot
+
+ ==> New default user and group
+
+ Instead of "nobody" lighttpd runs as user/group "http" by default now. You might
+ want to adjust your lighttpd.conf according to this change. But you can still
+ run lighttpd as nobody.
+ '
+ fi
+}
diff --git a/abs/core-testing/lighttpd/lighttpd.logrotate.d b/abs/core-testing/lighttpd/lighttpd.logrotate.d
new file mode 100644
index 0000000..15cacc9
--- /dev/null
+++ b/abs/core-testing/lighttpd/lighttpd.logrotate.d
@@ -0,0 +1,5 @@
+/var/log/lighttpd/*log {
+ postrotate
+ /bin/kill -HUP `cat /var/run/lighttpd/lighttpd.pid 2>/dev/null` 2> /dev/null || true
+ endscript
+}
diff --git a/abs/core-testing/lighttpd/lighttpd.rc.d b/abs/core-testing/lighttpd/lighttpd.rc.d
new file mode 100644
index 0000000..97c315f
--- /dev/null
+++ b/abs/core-testing/lighttpd/lighttpd.rc.d
@@ -0,0 +1,38 @@
+#!/bin/bash
+
+# general config
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/lighttpd`
+
+case "$1" in
+ start)
+ stat_busy "Starting lighttpd Daemon"
+ [ -z "$PID" ] && /usr/sbin/lighttpd -f /etc/lighttpd/lighttpd.conf 2>&1
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon lighttpd
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping lighttpd Daemon"
+ [ ! -z "$PID" ] && kill $PID &>/dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon lighttpd
+ rm -f /var/run/lighttpd/lighttpd.pid
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac