summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/lighttpd
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-04-06 02:35:44 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-04-06 02:35:44 (GMT)
commitc137477ca002b5c6c00462e4d4e3913e54b0fa4b (patch)
treea57bc4abe0fdae453b27ba791b3130f754eedbb1 /abs/core-testing/lighttpd
parentb82359d96ce6bae778fab9b24cfe69e93e41aa7b (diff)
downloadlinhes_pkgbuild-c137477ca002b5c6c00462e4d4e3913e54b0fa4b.zip
linhes_pkgbuild-c137477ca002b5c6c00462e4d4e3913e54b0fa4b.tar.gz
linhes_pkgbuild-c137477ca002b5c6c00462e4d4e3913e54b0fa4b.tar.bz2
lighttpd: add ability for server-side includes by default
turn on mod_proxy and mod_ssi by default configuration includes can go in /etc/lighttpd/conf.include html includes can go in /etc/lighttpd/html.include
Diffstat (limited to 'abs/core-testing/lighttpd')
-rw-r--r--abs/core-testing/lighttpd/PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/abs/core-testing/lighttpd/PKGBUILD b/abs/core-testing/lighttpd/PKGBUILD
index eea4367..0e43272 100644
--- a/abs/core-testing/lighttpd/PKGBUILD
+++ b/abs/core-testing/lighttpd/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lighttpd
pkgver=1.4.26
-pkgrel=11
+pkgrel=12
pkgdesc='a secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
@@ -65,19 +65,20 @@ build() {
-e 's|#server.pid-file = "/var/run/lighttpd.pid"|server.pid-file = "/var/run/lighttpd/lighttpd.pid"|' \
-e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
-e 's|"^/mythweb|"^/{1,2}mythweb|' \
+ -e 's|# "mod_proxy",| "mod_proxy",|' \
+ -e 's|# "mod_ssi",| "mod_ssi",|' \
+ -e 's|#ssi.extension = ( ".shtml" )|ssi.extension = ( ".shtml" )|' \
-i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
+ /bin/touch $pkgdir/etc/lighttpd/{conf,html}.include || return 1
+ /bin/echo 'include "/etc/lighttpd/conf.include"' >> $pkgdir/etc/lighttpd/lighttpd.conf || return 1
+ /bin/echo 'include "/etc/lighttpd/html.include"' >> $pkgdir/etc/lighttpd/lighttpd.conf || return 1
+
install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
}
md5sums=('a682c8efce47a2f4263a247ba0813c9b'
'bd690eee0d9e51857448770a151023b0'
'857e174643fd7761a2f0d8431a679f6c'
- '07b8459b54fb2e70280064c2a275b176'
- 'c6e361131000ceec085f40b310ef4a2c'
- '84c884b8dadd724afe2bc6529e9d4485')
-md5sums=('a682c8efce47a2f4263a247ba0813c9b'
- 'bd690eee0d9e51857448770a151023b0'
- '857e174643fd7761a2f0d8431a679f6c'
'11fbec7ff7ca1b0d5575445681e8f60e'
'c6e361131000ceec085f40b310ef4a2c'
'84c884b8dadd724afe2bc6529e9d4485')