summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/lighttpd
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-12-10 01:41:05 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-12-10 01:41:05 (GMT)
commitf77e676cfc7f6919fa6a4145180899afd4ad1fd6 (patch)
tree9f2b653bfbb4edbf57bcda815676956a6fa05c12 /abs/core-testing/lighttpd
parent8203006cf9ee68a8e33e30d48ea6b396d1a7b7e4 (diff)
downloadlinhes_pkgbuild-f77e676cfc7f6919fa6a4145180899afd4ad1fd6.zip
linhes_pkgbuild-f77e676cfc7f6919fa6a4145180899afd4ad1fd6.tar.gz
linhes_pkgbuild-f77e676cfc7f6919fa6a4145180899afd4ad1fd6.tar.bz2
Connect various pieces to dd password protection to /mythweb.
Disabled by default.
Diffstat (limited to 'abs/core-testing/lighttpd')
-rw-r--r--abs/core-testing/lighttpd/PKGBUILD7
-rw-r--r--abs/core-testing/lighttpd/_changelog1
-rw-r--r--abs/core-testing/lighttpd/auth-inc.conf12
-rw-r--r--abs/core-testing/lighttpd/lighttpd.conf12
-rw-r--r--abs/core-testing/lighttpd/lighttpd.install18
5 files changed, 27 insertions, 23 deletions
diff --git a/abs/core-testing/lighttpd/PKGBUILD b/abs/core-testing/lighttpd/PKGBUILD
index 0b42db7..db98bc4 100644
--- a/abs/core-testing/lighttpd/PKGBUILD
+++ b/abs/core-testing/lighttpd/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=lighttpd
pkgver=1.4.20
-pkgrel=6
+pkgrel=12
pkgdesc='a secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
@@ -15,11 +15,11 @@ optdepends=('libxml2: mod_webdav' \
'sqlite3: mod_webdav' \
'gdbm: mod_trigger_b4_dl' \
)
-backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd')
+backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd' 'etc/lighttpd/auth-inc.conf')
options=('!libtool' 'emptydirs')
install='lighttpd.install'
source=("http://www.lighttpd.net/download/lighttpd-${pkgver}.tar.bz2" \
- 'lighttpd.rc.d' 'lighttpd.logrotate.d' lighttpd.conf)
+ 'lighttpd.rc.d' 'lighttpd.logrotate.d' lighttpd.conf auth-inc.conf)
md5sums=('ed6ee0bb714f393219a32768d86984d8'
'bd690eee0d9e51857448770a151023b0'
@@ -64,6 +64,7 @@ build() {
# -e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
# -i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
install -D -m644 $startdir/src/lighttpd.conf $pkgdir/etc/lighttpd/lighttpd.conf
+ install -D -m644 $startdir/src/auth-inc.conf $pkgdir/etc/lighttpd/auth-inc.conf
install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
}
diff --git a/abs/core-testing/lighttpd/_changelog b/abs/core-testing/lighttpd/_changelog
index 202ea2f..439f42d 100644
--- a/abs/core-testing/lighttpd/_changelog
+++ b/abs/core-testing/lighttpd/_changelog
@@ -1 +1,2 @@
changed docroot to /data/srv/
+modified auth to require valid user (include auth-inc.conf)
diff --git a/abs/core-testing/lighttpd/auth-inc.conf b/abs/core-testing/lighttpd/auth-inc.conf
new file mode 100644
index 0000000..21c4c55
--- /dev/null
+++ b/abs/core-testing/lighttpd/auth-inc.conf
@@ -0,0 +1,12 @@
+auth.backend = "plain"
+auth.backend.plain.userfile = "/etc/lighttpd/lighttpd.user"
+
+
+auth.require = ( "/mythweb" =>
+ (
+ "method" => "basic",
+ "realm" => "MythWeb",
+ "require" => "valid-user"
+ )
+ )
+
diff --git a/abs/core-testing/lighttpd/lighttpd.conf b/abs/core-testing/lighttpd/lighttpd.conf
index efcd219..e2c60da 100644
--- a/abs/core-testing/lighttpd/lighttpd.conf
+++ b/abs/core-testing/lighttpd/lighttpd.conf
@@ -18,7 +18,7 @@ server.modules = (
"mod_access",
# "mod_cml",
# "mod_trigger_b4_dl",
-# "mod_auth",
+ "mod_auth",
# "mod_status",
"mod_setenv",
"mod_fastcgi",
@@ -263,12 +263,12 @@ cgi.assign = ( ".pl" => "/usr/bin/perl",
#auth.backend.ldap.base-dn = "dc=my-domain,dc=com"
#auth.backend.ldap.filter = "(uid=$)"
-#auth.require = ( "/server-status" =>
+#auth.require = ( "/mythweb =>
# (
-# "method" => "digest",
+# "method" => "plain",
# "realm" => "download archiv",
-# "require" => "user=jan"
-# ),
+# "require" => "valid-user"
+# )
# "/server-config" =>
# (
# "method" => "digest",
@@ -337,7 +337,7 @@ cgi.assign = ( ".pl" => "/usr/bin/perl",
#index-file.names += (foo + ".php")
#### include
-#include /etc/lighttpd/lighttpd-inc.conf
+#include "/etc/lighttpd/auth-inc.conf"
## same as above if you run: "lighttpd -f /etc/lighttpd/lighttpd.conf"
#include "lighttpd-inc.conf"
diff --git a/abs/core-testing/lighttpd/lighttpd.install b/abs/core-testing/lighttpd/lighttpd.install
index 9d98d41..bf4c132 100644
--- a/abs/core-testing/lighttpd/lighttpd.install
+++ b/abs/core-testing/lighttpd/lighttpd.install
@@ -1,16 +1,6 @@
+pre_upgrade() {
+ mv /etc/lighttpd/lighttpd.conf /etc/lighttpd/lighttpd.conf.old
+}
post_upgrade() {
- if [ $(vercmp '1.4.19-1' $2) -ge 0 ]; then
- echo '
- ==> New default DocumentRoot
-
- lighttpd uses /srv/http as default DocumentRoot.
- You can still use your current DocumentRoot
-
- ==> New default user and group
-
- Instead of "nobody" lighttpd runs as user/group "http" by default now. You might
- want to adjust your lighttpd.conf according to this change. But you can still
- run lighttpd as nobody.
- '
- fi
+ touch /etc/lighttpd/lighttpd.user
}