summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/linhes-live
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-07-06 04:54:16 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-07-06 04:54:16 (GMT)
commitbd85a03ffbbe362d9776483fb5cd5f5c3cdcd230 (patch)
treeb0a259292ce7ad1ec17821c372dfbb01e73e02fd /abs/core-testing/linhes-live
parent9b3f975dd88283ead8ec8cd05ffcb936311e2f51 (diff)
downloadlinhes_pkgbuild-bd85a03ffbbe362d9776483fb5cd5f5c3cdcd230.zip
linhes_pkgbuild-bd85a03ffbbe362d9776483fb5cd5f5c3cdcd230.tar.gz
linhes_pkgbuild-bd85a03ffbbe362d9776483fb5cd5f5c3cdcd230.tar.bz2
linhes-live: add ability to list modules on cmdline to load
modules=a,b,c
Diffstat (limited to 'abs/core-testing/linhes-live')
-rw-r--r--abs/core-testing/linhes-live/PKGBUILD2
-rw-r--r--abs/core-testing/linhes-live/etc/live-sysinit19
-rwxr-xr-xabs/core-testing/linhes-live/etc/rc.sysinit-live3
3 files changed, 23 insertions, 1 deletions
diff --git a/abs/core-testing/linhes-live/PKGBUILD b/abs/core-testing/linhes-live/PKGBUILD
index c1e4ff1..3367025 100644
--- a/abs/core-testing/linhes-live/PKGBUILD
+++ b/abs/core-testing/linhes-live/PKGBUILD
@@ -2,7 +2,7 @@
# 2008.09.25
pkgname=linhes-live
pkgver=5.3.3
-pkgrel=19
+pkgrel=24
pkgdesc="LinHes compulsory components for the Live System."
url="http://KnoppMyth.net"
diff --git a/abs/core-testing/linhes-live/etc/live-sysinit b/abs/core-testing/linhes-live/etc/live-sysinit
index abab4a8..0a49ae1 100644
--- a/abs/core-testing/linhes-live/etc/live-sysinit
+++ b/abs/core-testing/linhes-live/etc/live-sysinit
@@ -52,3 +52,22 @@ f_swapon ()
status "Activating Swap" /sbin/swapon -a
fi
}
+f_loadmodules()
+{
+ CMDLINE=$(cat /proc/cmdline)
+ echo $CMDLINE | grep -q modules
+ if [ $? -eq 0 ]
+ then
+ TEMPVAR=${CMDLINE#*modules=}
+ CMDMODULES=${TEMPVAR%% *}
+ mymod=`echo $CMDMODULES|/bin/sed 's|-|_|g' |/bin/sed 's|,| |g'`
+ stat_busy "Loading CMD module"
+ for mod in $mymod
+ do
+ /sbin/modprobe $mod
+ done
+ stat_done
+ fi
+
+
+}
diff --git a/abs/core-testing/linhes-live/etc/rc.sysinit-live b/abs/core-testing/linhes-live/etc/rc.sysinit-live
index 3f72a50..afdc2ae 100755
--- a/abs/core-testing/linhes-live/etc/rc.sysinit-live
+++ b/abs/core-testing/linhes-live/etc/rc.sysinit-live
@@ -176,6 +176,9 @@ fi
# Load modules from the MODULES array defined in rc.conf
if ! [ "$load_modules" = "off" ]; then
if [ -f /proc/modules ]; then
+############Added by jm to load modules from /proc/cmdline
+ f_loadmodules
+##############
stat_busy "Loading Modules"
for mod in "${MODULES[@]}"; do
if [ "$mod" = "${mod#!}" ]; then