summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh
diff options
context:
space:
mode:
authorBob Igo <bob@stormlogic.com>2009-08-03 18:27:55 (GMT)
committerBob Igo <bob@stormlogic.com>2009-08-03 18:27:55 (GMT)
commit3673d58e52b1df1d09fd64ef99934af1ecfcd214 (patch)
tree201f1655c927e519cadc23101e2a84b80665d338 /abs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh
parent1c8d8e45ae539f9cc20df8eafa9b7c47582d297e (diff)
downloadlinhes_pkgbuild-3673d58e52b1df1d09fd64ef99934af1ecfcd214.zip
linhes_pkgbuild-3673d58e52b1df1d09fd64ef99934af1ecfcd214.tar.gz
linhes_pkgbuild-3673d58e52b1df1d09fd64ef99934af1ecfcd214.tar.bz2
Extracted sources for linhes-scripts so each script gets version control; PKGBUILD changed to reflect this; also changed # of lines used by shootscreens-mythtv.sh to fit on low res displays
Diffstat (limited to 'abs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh')
-rwxr-xr-xabs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh16
1 files changed, 16 insertions, 0 deletions
diff --git a/abs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh b/abs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh
new file mode 100755
index 0000000..4aadf6d
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/src/mythwelcome-test-wakeup.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+sudo sh -c "echo 0 > /sys/class/rtc/rtc0/wakealarm" #this clears your alarm
+sudo sh -c "echo `date '+%s' -d '+ 4 minutes'` > /sys/class/rtc/rtc0/wakealarm" #this writes your alarm
+cat /proc/driver/rtc
+cat /proc/driver/rtc > /var/log/wake_alarm
+echo "Your computer is set to start up in 4 minutes using ACPI."
+echo -n "Do you want to shutdown the computer now? (y/n): "
+read -n 1 shutdown
+if [ "$shutdown" == "y" ]; then
+ echo -e "\nShutting down now..."
+ sudo shutdown -t 5 -h now
+else
+ echo -e "\nTo shutdown execute the following:"
+ echo " sudo shutdown -t 5 -h now"
+fi