summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/linhes-scripts
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-10-10 19:17:15 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-10-10 19:17:15 (GMT)
commitbd25e500073a8f8090509223e1e004e0d98f0a33 (patch)
tree5bac9bdae303f9ec2e3960f56795d2799975025d /abs/core-testing/linhes-scripts
parent78b6fbe8af13daca517897458d659fbfa9399e6a (diff)
downloadlinhes_pkgbuild-bd25e500073a8f8090509223e1e004e0d98f0a33.zip
linhes_pkgbuild-bd25e500073a8f8090509223e1e004e0d98f0a33.tar.gz
linhes_pkgbuild-bd25e500073a8f8090509223e1e004e0d98f0a33.tar.bz2
linhes-scripts:Added script for Hulu Desktop integration.
Diffstat (limited to 'abs/core-testing/linhes-scripts')
-rw-r--r--abs/core-testing/linhes-scripts/PKGBUILD5
-rw-r--r--abs/core-testing/linhes-scripts/install_hulu.sh66
2 files changed, 69 insertions, 2 deletions
diff --git a/abs/core-testing/linhes-scripts/PKGBUILD b/abs/core-testing/linhes-scripts/PKGBUILD
index 4b3244f..f84a5d2 100644
--- a/abs/core-testing/linhes-scripts/PKGBUILD
+++ b/abs/core-testing/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=linhes-scripts
pkgver=1
-pkgrel=35
+pkgrel=36
pkgdesc="Various scripts that help to make LinHES, LinHES."
arch=('i686' 'x86_64')
license=('GPL2')
@@ -32,12 +32,13 @@ run-limit-mythcommflag
linhes_update.sh
linhes_update2.sh
linhes_update3.sh
+install_hulu.sh
)
build() {
cd $startdir/src
mkdir -p $startdir/pkg/usr/LH/bin
- install -D -m755 myt* 770* idle.sh imp* shoo* *commflag*sh mplayer* vdpau* screen* linhes_* $startdir/pkg/usr/LH/bin
+ install -D -m755 myt* 770* idle.sh imp* shoo* *commflag*sh mplayer* vdpau* screen* linhes_* install_hulu.sh $startdir/pkg/usr/LH/bin
mkdir -p $startdir/pkg/etc/sv/pause-mythcommflag/supervise
cp run-pause-mythcommflag $startdir/pkg/etc/sv/pause-mythcommflag/run
mkdir -p $startdir/pkg/etc/sv/limit-mythcommflag/supervise
diff --git a/abs/core-testing/linhes-scripts/install_hulu.sh b/abs/core-testing/linhes-scripts/install_hulu.sh
new file mode 100644
index 0000000..f07a358
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/install_hulu.sh
@@ -0,0 +1,66 @@
+#!/bin/bash
+#install_hulu.sh
+if [ -e /tmp/huludesktop_i386.deb ]
+then
+cd /tmp
+deb2targz huludesktop_i386.deb
+tar -xzvf huludesktop_i386.tar.gz -C /
+else
+echo "Cannot find huludesktop_i386.deb."
+echo "Please download it from http://www.hulu.com/labs/hulu-desktop-linux"
+echo "Then copy (or move) it to /tmp"
+exit
+fi
+if grep -q Hulu /usr/share/mythtv/is.xml
+then
+echo "Hulu Desktop exist in Online Streams!"
+else
+ mv /usr/share/mythtv/is.xml /tmp
+ grep -v -e /mythmenu /tmp/is.xml > /tmp/is.xml.tmp
+ echo "<!--#Hulu-->" >> /tmp/is.xml.tmp
+ echo " <button>" >> /tmp/is.xml.tmp
+ echo " <type>STREAM</type>" >> /tmp/is.xml.tmp
+ echo " <text>Hulu Desktop</text>" >> /tmp/is.xml.tmp
+ echo " <action>EXEC huludesktop</action>" >> /tmp/is.xml.tmp
+ echo " </button>" >> /tmp/is.xml.tmp
+ echo "<!--#Hulu-->" >> /tmp/is.xml.tmp
+ echo "" >> /tmp/is.xml.tmp
+ echo "</mythmenu>" >> /tmp/is.xml.tmp
+ mv /tmp/is.xml.tmp /usr/share/mythtv/is.xml
+echo "Hulu Desktop has been added to Online Streams!"
+fi
+if [ -e /home/mythtv/.huludesktop ]
+then
+echo "Found existing Hulu configuration file."
+else
+cat >> /home/mythtv/.huludesktop << EOF
+[display]
+fullscreen = TRUE
+width = 1024
+height = 576
+pos_x = 201
+pos_y = 179
+
+[remote]
+lirc_device = /dev/lircd
+lirc_remote_identifier = mceusb
+lirc_release_suffix = _UP
+lirc_repeat_threshold = 10
+button_name_up = Up
+button_name_down = Down
+button_name_left = Left
+button_name_right = Right
+button_name_select = OK
+button_name_menu = Home
+
+[flash]
+flash_location = /usr/lib/mozilla/plugins/libflashplayer.so
+
+[version]
+latest = (null)
+eula_version = 0
+EOF
+chown mythtv.mythtv /home/mythtv/.huludesktop
+fi
+echo "Integration of Hulu Desktop is now complete!"
+echo "Thanks for using LinHES!"