summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/linhes-scripts
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-05-17 00:11:51 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-05-17 00:11:51 (GMT)
commite5126e66d4a1b426105c973c1c5b26ea680679c3 (patch)
treee2551bd019fcc73d05491f701ee38cb143918341 /abs/core-testing/linhes-scripts
parent6d48ddf2a2a1b840837f0edfb17890a38af05df6 (diff)
downloadlinhes_pkgbuild-e5126e66d4a1b426105c973c1c5b26ea680679c3.zip
linhes_pkgbuild-e5126e66d4a1b426105c973c1c5b26ea680679c3.tar.gz
linhes_pkgbuild-e5126e66d4a1b426105c973c1c5b26ea680679c3.tar.bz2
linhes-scripts:Bumped to add channel change scripts for DCT 700 and QIP 7100.
Diffstat (limited to 'abs/core-testing/linhes-scripts')
-rw-r--r--abs/core-testing/linhes-scripts/PKGBUILD8
-rw-r--r--abs/core-testing/linhes-scripts/dct700-cc.sh27
-rwxr-xr-xabs/core-testing/linhes-scripts/qip7100-cc.sh25
3 files changed, 58 insertions, 2 deletions
diff --git a/abs/core-testing/linhes-scripts/PKGBUILD b/abs/core-testing/linhes-scripts/PKGBUILD
index ee22701..4694905 100644
--- a/abs/core-testing/linhes-scripts/PKGBUILD
+++ b/abs/core-testing/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=linhes-scripts
pkgver=1
-pkgrel=68
+pkgrel=69
pkgdesc="Various scripts that help to make LinHES, LinHES."
arch=('i686' 'x86_64')
license=('GPL2')
@@ -41,6 +41,8 @@ remove_php_mythvideo.sh
removecommercials.sh
system-cleanup.sh
myth2fuze
+dct700-cc.sh
+qip7100-cc.sh
)
build() {
@@ -83,4 +85,6 @@ md5sums=('f56985b2d602e11dc1e10d3e7848b2a5'
'87b0dc855181f98516acb18a7d551601'
'25c1baeb97a49656456ae33f7e7a9f06'
'2fb25aef03ffd1282414d8cca3df7056'
- '1b355d227dcd954960c677f5e4f2379d')
+ '1b355d227dcd954960c677f5e4f2379d'
+ 'df727c98350a64e2171c950bbefc9c5d'
+ '7b890e7044db38e8d439f67e398af206')
diff --git a/abs/core-testing/linhes-scripts/dct700-cc.sh b/abs/core-testing/linhes-scripts/dct700-cc.sh
new file mode 100644
index 0000000..c8d8cf6
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/dct700-cc.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+#Script to control DCT 700/2524 on emitter #1 of CommandIR
+irsend set_transmitters 1
+REMOTE_NAME=DCT700
+cmd="$1"
+irsend -d /dev/lircd SEND_ONCE $REMOTE_NAME menu
+sleep 1
+irsend -d /dev/lircd SEND_ONCE $REMOTE_NAME exit
+sleep 1
+
+case $cmd in
+ [0-9]*)
+ for digit in $(echo $1 | sed -e 's/./& /g'); do
+ irsend -d /dev/lircd SEND_ONCE $REMOTE_NAME $digit
+ sleep .2
+ # If things work OK with sleep 1, try this for faster channel changes:
+ # sleep 0.3
+ done
+ irsend -d /dev/lircd SEND_ONCE $REMOTE_NAME ok
+sleep .3
+ irsend -d /dev/lircd SEND_ONCE $REMOTE_NAME exit
+ ;;
+
+ *)
+ irsend SEND_ONCE $REMOTE_NAME $cmd
+ ;;
+esac
diff --git a/abs/core-testing/linhes-scripts/qip7100-cc.sh b/abs/core-testing/linhes-scripts/qip7100-cc.sh
new file mode 100755
index 0000000..029e25c
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/qip7100-cc.sh
@@ -0,0 +1,25 @@
+#!/bin/bash
+#Script to control DCT 700/2524 on emitter #1 of CommandIR
+irsend set_transmitters 2
+sleep .5
+#REMOTE_NAME=DCT2524
+REMOTE_NAME=Motorola_QIP6200-2
+cmd="$1"
+
+case $cmd in
+ [0-9]*)
+ for digit in $(echo $1 | sed -e 's/./& /g'); do
+ irsend -d /dev/lircd SEND_ONCE $REMOTE_NAME $digit
+ sleep .4
+ # If things work OK with sleep 1, try this for faster channel changes:
+ sleep 0.3
+ done
+ irsend -d /dev/lircd SEND_ONCE $REMOTE_NAME ok
+sleep .3
+ irsend -d /dev/lircd SEND_ONCE $REMOTE_NAME exit
+ ;;
+
+ *)
+ irsend SEND_ONCE $REMOTE_NAME $cmd
+ ;;
+esac