summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/lirc
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-02-27 09:03:13 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-02-27 09:03:13 (GMT)
commit2144c0e196d48e5a091b66aeb8ab444ff119269e (patch)
treee90397b1be24c5fb239cbf1c76d76bb3b08dd28e /abs/core-testing/lirc
parenta24e76ac094b2c26d12b867a12587d2c0409dc3f (diff)
downloadlinhes_pkgbuild-2144c0e196d48e5a091b66aeb8ab444ff119269e.zip
linhes_pkgbuild-2144c0e196d48e5a091b66aeb8ab444ff119269e.tar.gz
linhes_pkgbuild-2144c0e196d48e5a091b66aeb8ab444ff119269e.tar.bz2
Added lirc_mod_mce.
Diffstat (limited to 'abs/core-testing/lirc')
-rw-r--r--abs/core-testing/lirc/PKGBUILD15
-rw-r--r--abs/core-testing/lirc/lirc_mod_mce.patch12
2 files changed, 24 insertions, 3 deletions
diff --git a/abs/core-testing/lirc/PKGBUILD b/abs/core-testing/lirc/PKGBUILD
index ef2359b..f6fff65 100644
--- a/abs/core-testing/lirc/PKGBUILD
+++ b/abs/core-testing/lirc/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lirc
pkgver=0.8.5CVS
-pkgrel=1
+pkgrel=2
_kernver=2.6.28-LinHES
pkgdesc="Linux Infrared Remote Control kernel modules for stock arch kernel"
arch=(i686 x86_64)
@@ -17,7 +17,9 @@ install=$pkgname.install
source=(http://www.blushingpenguin.com/mark/lmilk/lirc-0.8.5-CVS-pvr150.tar.bz2 \
kernel-2.6.26.patch
kernel-2.6.27.patch
- lirc_atiusb.patch)
+ lirc_atiusb.patch
+ http://superb-east.dl.sourceforge.net/sourceforge/mod-mce/lirc_mod_mce-0.2.0.tar.bz2
+ lirc_mod_mce.patch)
build() {
# configure
@@ -50,7 +52,14 @@ build() {
# set the kernel we've built for inside the install script
sed -i -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
$startdir/lirc.install || return 1
+ cd $startdir/src/lirc_mod_mce
+ cp ../lirc-0.8.5-CVS-pvr150/drivers/lirc_dev/lirc_dev.h .
+ patch -p1 < ../lirc_mod_mce.patch
+ make KDIR=/usr/src/linux-2.6.28-LinHES/
+ cp lirc_mod_mce.ko $startdir/pkg/lib/modules/2.6.28-LinHES/kernel/drivers/misc/
}
md5sums=('8f3ba7eb57529992f3991d6981a3feb6'
'1753acd774f50b638e6173d364de53fd'
- '6f151eb4e81fc7776a06c9063e6ad9a5')
+ '6f151eb4e81fc7776a06c9063e6ad9a5'
+ '563f992342df81317fe4ae2b1157cc5e'
+ 'a966b297a0768386f845348f736c6db3')
diff --git a/abs/core-testing/lirc/lirc_mod_mce.patch b/abs/core-testing/lirc/lirc_mod_mce.patch
new file mode 100644
index 0000000..0d07995
--- /dev/null
+++ b/abs/core-testing/lirc/lirc_mod_mce.patch
@@ -0,0 +1,12 @@
+diff -ruaN lirc_mod_mce.orig/lirc_mod_mce.c lirc_mod_mce/lirc_mod_mce.c
+--- lirc_mod_mce.orig/lirc_mod_mce.c 2008-04-26 08:42:47.000000000 +0000
++++ lirc_mod_mce/lirc_mod_mce.c 2009-02-27 08:50:31.000000000 +0000
+@@ -1298,7 +1298,7 @@
+ input_dev->name = ir->name;
+ input_dev->phys = ir->phys;
+ usb_to_input_id(dev, &input_dev->id);
+- input_dev->cdev.dev = &dev->dev;
++ input_dev->dev.parent = &dev->dev;
+ input_dev->evbit[BIT_WORD(EV_KEY)] |= BIT_MASK(EV_KEY);
+ input_dev->evbit[BIT_WORD(EV_REL)] |= BIT_MASK(EV_REL);
+ input_dev->relbit[BIT_WORD(REL_X)] |= BIT_MASK(REL_X);