summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/lirc
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-05 03:41:49 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-05 03:41:49 (GMT)
commitaaaed3a6a08206d2d16665695a622a48da869eaf (patch)
treeff54106ef2ad3b9f9a3220ed0e4251d76627b904 /abs/core-testing/lirc
parent7f42f55d022dc8ca818a76dccfc66fce7c8dea4f (diff)
downloadlinhes_pkgbuild-aaaed3a6a08206d2d16665695a622a48da869eaf.zip
linhes_pkgbuild-aaaed3a6a08206d2d16665695a622a48da869eaf.tar.gz
linhes_pkgbuild-aaaed3a6a08206d2d16665695a622a48da869eaf.tar.bz2
Additional packages needed for Miro. Latest LIRC PKGBUILD from Arch.
Diffstat (limited to 'abs/core-testing/lirc')
-rw-r--r--abs/core-testing/lirc/PKGBUILD16
-rw-r--r--abs/core-testing/lirc/kernel-2.6.27.patch78
-rw-r--r--abs/core-testing/lirc/lirc.install6
3 files changed, 91 insertions, 9 deletions
diff --git a/abs/core-testing/lirc/PKGBUILD b/abs/core-testing/lirc/PKGBUILD
index d7fc488..4548a46 100644
--- a/abs/core-testing/lirc/PKGBUILD
+++ b/abs/core-testing/lirc/PKGBUILD
@@ -1,27 +1,28 @@
-# $Id: PKGBUILD 6055 2008-07-23 02:44:55Z eric $
+# $Id: PKGBUILD 14978 2008-10-11 21:04:37Z tpowa $
# Maintainer: Paul Mattal <paul@archlinux.org>
pkgname=lirc
pkgver=0.8.3
-pkgrel=1
-_kernver=2.6.26-ARCH
+pkgrel=3
+_kernver=2.6.27-ARCH
pkgdesc="Linux Infrared Remote Control kernel modules for stock arch kernel"
arch=(i686 x86_64)
url="http://www.lirc.org/"
license=('GPL')
-depends=('lirc-utils=0.8.3' 'kernel26>=2.6.26-1' 'kernel26<2.6.27')
+depends=('lirc-utils=0.8.3' 'kernel26>=2.6.27' 'kernel26<2.6.28')
makedepends=('help2man')
replaces=('lirc+pctv')
options=('!makeflags')
install=$pkgname.install
source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2 \
- kernel-2.6.26.patch)
-md5sums=('8e78eeded7b31e5ad02e328970437c0f' '1753acd774f50b638e6173d364de53fd')
+ kernel-2.6.26.patch
+ kernel-2.6.27.patch)
build() {
# configure
cd $startdir/src/lirc-$pkgver || return 1
patch -Np1 -i ../kernel-2.6.26.patch || return 1
+ patch -Np1 -i ../kernel-2.6.27.patch || return 1
./configure --enable-sandboxed --prefix=/usr \
--with-driver=all --with-kerneldir=/usr/src/linux-${_kernver}/ \
@@ -48,3 +49,6 @@ build() {
sed -i -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
$startdir/lirc.install || return 1
}
+md5sums=('8e78eeded7b31e5ad02e328970437c0f'
+ '1753acd774f50b638e6173d364de53fd'
+ '6f151eb4e81fc7776a06c9063e6ad9a5')
diff --git a/abs/core-testing/lirc/kernel-2.6.27.patch b/abs/core-testing/lirc/kernel-2.6.27.patch
new file mode 100644
index 0000000..05cf75b
--- /dev/null
+++ b/abs/core-testing/lirc/kernel-2.6.27.patch
@@ -0,0 +1,78 @@
+diff -Nur lirc-0.8.3.orig/drivers/lirc_dev/lirc_dev.c lirc-0.8.3/drivers/lirc_dev/lirc_dev.c
+--- lirc-0.8.3.orig/drivers/lirc_dev/lirc_dev.c 2008-01-13 11:45:02.000000000 +0100
++++ lirc-0.8.3/drivers/lirc_dev/lirc_dev.c 2008-10-10 16:29:15.000000000 +0200
+@@ -49,7 +49,7 @@
+ #include <linux/uaccess.h>
+ #include <linux/errno.h>
+ #endif
+-#include <asm/semaphore.h>
++#include <linux/semaphore.h>
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0)
+ #include <linux/wrapper.h>
+ #endif
+diff -Nur lirc-0.8.3.orig/drivers/lirc_i2c/lirc_i2c.c lirc-0.8.3/drivers/lirc_i2c/lirc_i2c.c
+--- lirc-0.8.3.orig/drivers/lirc_i2c/lirc_i2c.c 2008-05-04 15:49:53.000000000 +0200
++++ lirc-0.8.3/drivers/lirc_i2c/lirc_i2c.c 2008-10-10 16:29:00.000000000 +0200
+@@ -54,7 +54,7 @@
+ #include <linux/i2c.h>
+ #include <linux/i2c-algo-bit.h>
+
+-#include <asm/semaphore.h>
++#include <linux/semaphore.h>
+
+ #include "drivers/kcompat.h"
+ #include "drivers/lirc_dev/lirc_dev.h"
+--- lirc-0.8.3.orig/drivers/kcompat.h 2008/05/14 16:37:49 5.36
++++ lirc-0.8.3.orig/drivers/kcompat.h 2008/09/27 08:16:15 5.37
+@@ -36,7 +36,7 @@
+ class_simple_destroy(cls);
+ }
+
+-#define lirc_device_create(cs, parent, dev, fmt, args...) \
++#define lirc_device_create(cs, parent, dev, drvdata, fmt, args...) \
+ class_simple_device_add(cs, dev, parent, fmt, ## args)
+
+ static inline void lirc_device_destroy(lirc_class_t *cls, dev_t devt)
+@@ -48,20 +48,29 @@
+
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 15)
+
+-#define lirc_device_create(cs, parent, dev, fmt, args...) \
++#define lirc_device_create(cs, parent, dev, drvdata, fmt, args...) \
+ class_device_create(cs, dev, parent, fmt, ## args)
+
+ #else /* >= 2.6.15 */
+
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 26)
+
+-#define lirc_device_create(cs, parent, dev, fmt, args...) \
++#define lirc_device_create(cs, parent, dev, drvdata, fmt, args...) \
+ class_device_create(cs, NULL, dev, parent, fmt, ## args)
+
+ #else /* >= 2.6.26 */
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 27)
++
++#define lirc_device_create(cs, parent, dev, drvdata, fmt, args...) \
++ class_device_create(cs, parent, dev, fmt, ## args)
++
++#else /* >= 2.6.27 */
++
+ #define lirc_device_create device_create
+
++#endif /* >= 2.6.27 */
++
+ #endif /* >= 2.6.26 */
+
+ #define LIRC_DEVFS_PREFIX
+--- lirc-0.8.3.orig/drivers/lirc_dev/lirc_dev.c 2008/09/06 07:30:16 1.60
++++ lirc-0.8.3.orig/drivers/lirc_dev/lirc_dev.c 2008/09/27 08:16:15 1.61
+@@ -397,7 +397,7 @@
+ DEV_LIRC "/%u", ir->p.minor);
+ #endif
+ (void) lirc_device_create(lirc_class, ir->p.dev,
+- MKDEV(IRCTL_DEV_MAJOR, ir->p.minor),
++ MKDEV(IRCTL_DEV_MAJOR, ir->p.minor), NULL,
+ "lirc%u", ir->p.minor);
+
+ if (p->sample_rate || p->get_queue) {
diff --git a/abs/core-testing/lirc/lirc.install b/abs/core-testing/lirc/lirc.install
index 704c341..1320758 100644
--- a/abs/core-testing/lirc/lirc.install
+++ b/abs/core-testing/lirc/lirc.install
@@ -10,7 +10,7 @@ pre_install() {
post_install() {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
- KERNEL_VERSION=2.6.26-ARCH
+ KERNEL_VERSION=2.6.27-ARCH
depmod -v $KERNEL_VERSION > /dev/null 2>&1
/bin/true
}
@@ -26,7 +26,7 @@ pre_upgrade() {
post_upgrade() {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
- KERNEL_VERSION=2.6.26-ARCH
+ KERNEL_VERSION=2.6.27-ARCH
depmod -v $KERNEL_VERSION > /dev/null 2>&1
/bin/true
}
@@ -40,7 +40,7 @@ pre_remove() {
post_remove() {
# updating module dependencies
echo ">>> Updating module dependencies. Please wait ..."
- KERNEL_VERSION=2.6.26-ARCH
+ KERNEL_VERSION=2.6.27-ARCH
depmod -v $KERNEL_VERSION > /dev/null 2>&1
/bin/true
}