summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/lirc
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-02-14 22:38:28 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-02-14 22:38:28 (GMT)
commitb5695b4373628c91d8fbc15905c33ea24de081ef (patch)
treecea827372f7ceaf127d6e07f976199c1d510713a /abs/core-testing/lirc
parentd36b43424fc5063e01b8112d3fa7b432636668d0 (diff)
downloadlinhes_pkgbuild-b5695b4373628c91d8fbc15905c33ea24de081ef.zip
linhes_pkgbuild-b5695b4373628c91d8fbc15905c33ea24de081ef.tar.gz
linhes_pkgbuild-b5695b4373628c91d8fbc15905c33ea24de081ef.tar.bz2
Bumped, added patch for ATI Remote Wonder Plus.
Diffstat (limited to 'abs/core-testing/lirc')
-rw-r--r--abs/core-testing/lirc/PKGBUILD6
-rw-r--r--abs/core-testing/lirc/lirc_atiusb.patch27
2 files changed, 31 insertions, 2 deletions
diff --git a/abs/core-testing/lirc/PKGBUILD b/abs/core-testing/lirc/PKGBUILD
index 8dca358..5604fa8 100644
--- a/abs/core-testing/lirc/PKGBUILD
+++ b/abs/core-testing/lirc/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lirc
pkgver=0.8.4
-pkgrel=7
+pkgrel=8
_kernver=2.6.28-LinHES
pkgdesc="Linux Infrared Remote Control kernel modules for stock arch kernel"
arch=(i686 x86_64)
@@ -16,13 +16,15 @@ options=('!makeflags')
install=$pkgname.install
source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2 \
kernel-2.6.26.patch
- kernel-2.6.27.patch)
+ kernel-2.6.27.patch
+ lirc_atiusb.patch)
build() {
# configure
cd $startdir/src/lirc-$pkgver || return 1
# patch -Np1 -i ../kernel-2.6.26.patch || return 1
# patch -Np1 -i ../kernel-2.6.27.patch || return 1
+ patch -Np1 -i ../lirc_atiusb.patch || return 1
./configure --enable-sandboxed --prefix=/usr \
--with-driver=all --with-kerneldir=/usr/src/linux-${_kernver}/ \
diff --git a/abs/core-testing/lirc/lirc_atiusb.patch b/abs/core-testing/lirc/lirc_atiusb.patch
new file mode 100644
index 0000000..2f0c61e
--- /dev/null
+++ b/abs/core-testing/lirc/lirc_atiusb.patch
@@ -0,0 +1,27 @@
+diff -ruaN lirc-0.8.4.orig/drivers/lirc_atiusb/lirc_atiusb.c lirc-0.8.4/drivers/lirc_atiusb/lirc_atiusb.c
+--- lirc-0.8.4.orig/drivers/lirc_atiusb/lirc_atiusb.c 2008-05-19 08:10:35.000000000 +0000
++++ lirc-0.8.4/drivers/lirc_atiusb/lirc_atiusb.c 2009-02-14 22:35:44.000000000 +0000
+@@ -192,8 +192,9 @@
+ /* init strings */
+ #define USB_OUTLEN 7
+
+-static char init1[] = {0x01, 0x00, 0x20, 0x14};
+-static char init2[] = {0x01, 0x00, 0x20, 0x14, 0x20, 0x20, 0x20};
++static char init1[] = {0x80, 0x05, 0x1b, 0x15, 0x14, 0x20, 0x24, 0x15};
++static char init2[] = {0x83, 0x03};
++static char init3[] = {0x84, 0xd7, 0x020};
+
+ struct in_endpt {
+ /* inner link in list of endpoints for the remote specified by ir */
+@@ -1183,8 +1184,9 @@
+ oep->buf, USB_OUTLEN, usb_remote_send,
+ oep, oep->ep->bInterval);
+
+- send_packet(oep, 0x8004, init1);
+- send_packet(oep, 0x8007, init2);
++ send_packet(oep, 0x8007, init1);
++ send_packet(oep, 0x8002, init2);
++ send_packet(oep, 0x8003, init3);
+ }
+ }
+