summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/local-website/htdocs/mythtv-doc/Makefile
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-10-23 01:40:37 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-10-23 01:40:37 (GMT)
commit7f24a313f0815854ff88a0e33a066a73de4f3be1 (patch)
tree63f1de317bd6d4d3b283939c3481c3ed3e4e71f9 /abs/core-testing/local-website/htdocs/mythtv-doc/Makefile
parentde2ffe85032410437eb7dabdec63031e908fd43c (diff)
downloadlinhes_pkgbuild-7f24a313f0815854ff88a0e33a066a73de4f3be1.zip
linhes_pkgbuild-7f24a313f0815854ff88a0e33a066a73de4f3be1.tar.gz
linhes_pkgbuild-7f24a313f0815854ff88a0e33a066a73de4f3be1.tar.bz2
initial checkin of lighttpd and supporting libs.
Also included is a new package callede local-website. This package contains the contents of http://localhost that runs on every LinHES box. The initial checkin is taken from R5.5
Diffstat (limited to 'abs/core-testing/local-website/htdocs/mythtv-doc/Makefile')
-rw-r--r--abs/core-testing/local-website/htdocs/mythtv-doc/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/abs/core-testing/local-website/htdocs/mythtv-doc/Makefile b/abs/core-testing/local-website/htdocs/mythtv-doc/Makefile
new file mode 100644
index 0000000..0368fd2
--- /dev/null
+++ b/abs/core-testing/local-website/htdocs/mythtv-doc/Makefile
@@ -0,0 +1,42 @@
+# To build this stuff, you need the linuxdoc tools and htmldoc. On Debian,
+# this means: linuxdoc-tools linuxdoc-tools-text htmldoc
+#
+# - mdz
+
+TARGETS = mythtv-HOWTO.txt mythtv-HOWTO.html mythtv-HOWTO-singlehtml.html mythtv-HOWTO.pdf index.html
+LINUXDOC_HTML_SPLIT := 1
+
+all: $(TARGETS)
+clean:
+ rm -f $(TARGETS) $(patsubst %.html,%-[0-9]*.html,$(filter %.html,$(TARGETS)))
+ rm -Rf doxygen-dev-docs doxygen-warnings.txt
+
+distclean: clean
+
+validate: mythtv-HOWTO.sgml
+ linuxdoc -B check $<
+
+%.txt: %.sgml
+ linuxdoc -B txt $<
+
+# Generate PDF via LaTeX using linuxdoc
+#%.pdf: %.sgml
+# linuxdoc -B latex -o pdf $<
+
+# Generate PDF via HTML using htmldoc
+%.pdf: %-singlehtml.html
+ # htmldoc exits unsuccessfully for no good reason -mdz
+ htmldoc --book --quiet --outfile $@ $< || true
+
+%.html: %.sgml
+ linuxdoc -B html --split=$(LINUXDOC_HTML_SPLIT) --toc=2 $<
+
+%-singlehtml.html: LINUXDOC_HTML_SPLIT=0
+%-singlehtml.sgml: %.sgml
+ cp $< $@
+
+index.html: mythtv-HOWTO.html
+ cp $< $@
+
+devdocs:
+ doxygen doxygen-create-developer-docs.cfg