summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/lshw/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
commitc38715641e214272ad7dc6d495edd29940366e7f (patch)
tree9dcd507543e67458d98fa7462f62026041524047 /abs/core-testing/lshw/PKGBUILD
parent3d91b06198a56b6579cb0bd77de65f5908571b87 (diff)
downloadlinhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.zip
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.gz
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.bz2
packages that will be needed in the future.
This is the initial merge of packages from MythVantage that are not MythVantage specific.
Diffstat (limited to 'abs/core-testing/lshw/PKGBUILD')
-rw-r--r--abs/core-testing/lshw/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core-testing/lshw/PKGBUILD b/abs/core-testing/lshw/PKGBUILD
new file mode 100644
index 0000000..b2d786b
--- /dev/null
+++ b/abs/core-testing/lshw/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Stefano Zamprogno <stefano dot zamprogno at gmail dot com>
+# Contributor: Chuck Yang <Chuck.Yang@gmail.com>
+
+pkgname=lshw
+pkgver=B.02.13
+pkgrel=1
+pkgdesc="A small tool to provide detailed information on the hardware configuration of the machine."
+url="http://ezix.org/project/wiki/HardwareLiSter"
+license=('GPL')
+source=(http://ezix.org/software/files/lshw-B.02.13.tar.gz abi_stdlib.diff)
+md5sums=('e94c728ed037ca706436b5ef71aa392d' '8696f9e8ecb71bedf374b538e8634d2d')
+arch=('i686' 'x86_64')
+depends=('gtk2')
+makedepends=('gcc')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+
+ patch -Np0 -i ../abi_stdlib.diff || return 1
+
+ make || return 1
+ make gui || return 1
+ make DESTDIR=$startdir/pkg/ install
+ make DESTDIR=$startdir/pkg/ install-gui
+}
+