summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/miscsplashutils
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-02-12 08:22:14 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-02-12 08:22:14 (GMT)
commit40727c47f4a6319dc101ca97cddd72732db03889 (patch)
treec469bd876c58981ef4abd517af7af7f6c8f8868a /abs/core-testing/miscsplashutils
parentd39d6198243375c7cc8e72aa926d24fc6b625982 (diff)
downloadlinhes_pkgbuild-40727c47f4a6319dc101ca97cddd72732db03889.zip
linhes_pkgbuild-40727c47f4a6319dc101ca97cddd72732db03889.tar.gz
linhes_pkgbuild-40727c47f4a6319dc101ca97cddd72732db03889.tar.bz2
Initial inclusion of fbsplash and deps.
Diffstat (limited to 'abs/core-testing/miscsplashutils')
-rw-r--r--abs/core-testing/miscsplashutils/ChangeLog3
-rw-r--r--abs/core-testing/miscsplashutils/PKGBUILD26
-rw-r--r--abs/core-testing/miscsplashutils/miscsplashutils.install39
3 files changed, 68 insertions, 0 deletions
diff --git a/abs/core-testing/miscsplashutils/ChangeLog b/abs/core-testing/miscsplashutils/ChangeLog
new file mode 100644
index 0000000..811f87d
--- /dev/null
+++ b/abs/core-testing/miscsplashutils/ChangeLog
@@ -0,0 +1,3 @@
+2007-06-28 tardo <tardo@nagi-fanboi.net>
+* Built for x86_64
+
diff --git a/abs/core-testing/miscsplashutils/PKGBUILD b/abs/core-testing/miscsplashutils/PKGBUILD
new file mode 100644
index 0000000..e0b85c8
--- /dev/null
+++ b/abs/core-testing/miscsplashutils/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+
+pkgname=miscsplashutils
+pkgver=0.1.8
+pkgrel=1
+pkgdesc="Miscellaneous framebuffer utilities including fbres and fbtruetype"
+arch=(i686 x86_64)
+url="http://dev.gentoo.org/~spock/projects/gensplash/"
+license=('GPL')
+depends=('freetype2')
+conflicts=('bootsplash')
+install=miscsplashutils.install
+source=(http://dev.gentoo.org/~spock/projects/gensplash/current/$pkgname-$pkgver.tar.bz2)
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ make || return 1
+ make DESTDIR=$startdir/pkg/ install
+
+ install -d $startdir/pkg/lib/splash/bin
+ touch $startdir/pkg/lib/splash/bin/wc
+
+ # install luxisri.ttf to avoid an x-server dependency
+ install -D -m644 fbtruetype/luxisri.ttf $startdir/pkg/etc/splash/luxisri.ttf
+}
+md5sums=('0a9505c5c5ed169e6158d2c1b06ff40b')
diff --git a/abs/core-testing/miscsplashutils/miscsplashutils.install b/abs/core-testing/miscsplashutils/miscsplashutils.install
new file mode 100644
index 0000000..4345f5d
--- /dev/null
+++ b/abs/core-testing/miscsplashutils/miscsplashutils.install
@@ -0,0 +1,39 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+/bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+echo " : Copying /usr/bin/wc to /lib/splash/bin"
+install -D -m755 /usr/bin/wc /lib/splash/bin/wc
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+/bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+post_install
+}
+
+# arg 1: the old package version
+pre_remove() {
+/bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+/bin/true
+}
+
+op=$1
+shift
+$op $*