summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mjpegtools
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-18 15:12:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-18 15:12:00 (GMT)
commit89772f637e924a487058922db092be0f88a9f885 (patch)
tree2530c4810ee45d7530e311237134bc74b0453785 /abs/core-testing/mjpegtools
parent76683fbc211ac8e681763ba94ab417d0961dbf41 (diff)
downloadlinhes_pkgbuild-89772f637e924a487058922db092be0f88a9f885.zip
linhes_pkgbuild-89772f637e924a487058922db092be0f88a9f885.tar.gz
linhes_pkgbuild-89772f637e924a487058922db092be0f88a9f885.tar.bz2
Recompiled imagemagick,mjpegtools,transcode in an attempt to find something that works for mytharchive.
This combo appears to work.
Diffstat (limited to 'abs/core-testing/mjpegtools')
-rw-r--r--abs/core-testing/mjpegtools/PKGBUILD47
1 files changed, 29 insertions, 18 deletions
diff --git a/abs/core-testing/mjpegtools/PKGBUILD b/abs/core-testing/mjpegtools/PKGBUILD
index 8607886..4b85e30 100644
--- a/abs/core-testing/mjpegtools/PKGBUILD
+++ b/abs/core-testing/mjpegtools/PKGBUILD
@@ -1,18 +1,29 @@
- pkgname=mjpegtools
- pkgver=1.9.0
- pkgrel=2
- pkgdesc="The mjpeg programs are a set of tools that can do recording of videos and playback, simple cut-and-paste editing and the MPEG compression of audio and video under Linux. "
- arch=(i686 x86_64)
- license=('GPL')
- url="http://mjpeg.sourceforge.net/"
- depends=('libjpeg' 'libpng' 'gcc-libs' 'libdv')
- makedepends=('gtk2')
- options=('!makeflags' '!libtool')
- source=(http://downloads.sourceforge.net/sourceforge/mjpeg/${pkgname}-${pkgver}.tar.gz
- mjpegtools-1.8.0-gcc41.patch mjpegtools-1.8.0-libc.patch )
-
- build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- ./configure --prefix=/usr
- find -name Makefile -exec sed -i -e 's:-march=k8 -mtune=k8::' -e 's:-march=pentium3 -mtune=pentium3::' {} \;
- }
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+# Mantainer: Roberto Carvajal <roberto@archlinux.org>
+
+pkgname=mjpegtools
+pkgver=1.9.0
+pkgrel=3
+pkgdesc="The mjpeg programs are a set of tools that can do recording of videos and playback, simple cut-and-paste editing and the MPEG compression of audio and video under Linux. "
+arch=(i686 x86_64)
+license=('GPL')
+url="http://mjpeg.sourceforge.net/"
+depends=('libjpeg' 'libpng' 'sdl' 'gcc' 'libdv')
+makedepends=('gtk2')
+options=('!makeflags' '!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/mjpeg/${pkgname}-${pkgver}.tar.gz
+ mjpegtools-1.8.0-gcc41.patch)
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ # patch -Np1 -i ${startdir}/src/mjpegtools-1.8.0-gcc41.patch || return 1
+ ./configure --prefix=/usr
+ find -name Makefile -exec sed -i -e 's:-march=k8 -mtune=k8::' -e 's:-march=pentium3 -mtune=pentium3::' {} \;
+
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+
+ install -m644 mpeg2enc/mpeg2syntaxcodes.h \
+ ${startdir}/pkg/usr/include/mjpegtools/mpeg2enc/
+}