summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mpfr/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-08 07:33:44 (GMT)
commit525753e4a1a139e088d8ac120b19fbab6c0aaaa6 (patch)
tree35cef28abb613da4f58e83f6abbe4bd4cfa244bf /abs/core-testing/mpfr/PKGBUILD
parent592e3cad43ef12c53f523145d0fd981b54f2a049 (diff)
parentb172f79fadb565ecfbcec9508f9377d8618a4f4c (diff)
downloadlinhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.zip
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.gz
linhes_pkgbuild-525753e4a1a139e088d8ac120b19fbab6c0aaaa6.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/mpfr/PKGBUILD')
-rw-r--r--abs/core-testing/mpfr/PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/abs/core-testing/mpfr/PKGBUILD b/abs/core-testing/mpfr/PKGBUILD
index ac2ab77..e53757b 100644
--- a/abs/core-testing/mpfr/PKGBUILD
+++ b/abs/core-testing/mpfr/PKGBUILD
@@ -1,26 +1,29 @@
-# $Id: PKGBUILD 12992 2008-09-25 17:47:29Z jgc $
+# $Id: PKGBUILD 82426 2010-06-11 05:51:29Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: damir <damir@archlinux.org>
pkgname=mpfr
-pkgver=2.3.2
-pkgrel=2
-pkgdesc="multiple-precision floating-point library"
-arch=(i686 x86_64)
-license=('GPL' 'LGPL')
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Multiple-precision floating-point library"
+arch=('i686' 'x86_64')
+license=('LGPL')
url="http://www.mpfr.org/"
-depends=('gmp>=4.2.3' 'texinfo')
+depends=('gmp>=5.0')
options=('!libtool')
install=mpfr.install
-#source=(http://www.mpfr.org/mpfr-current/mpfr-${pkgver}.tar.gz)
+source=(http://www.mpfr.org/mpfr-current/mpfr-${pkgver}.tar.xz)
+md5sums=('8ab3bef2864b8c6e6a291f5603141bbd')
-source=(http://modular.math.washington.edu/home/novocin/tars/mpfr-2.3.2.tar.gz)
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --enable-thread-safe --enable-shared || return 1
make || return 1
+ make check || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install || return 1
- cd "${pkgdir}/usr/share/info" || return 1
- rm -f dir
- gzip * || return 1
}