summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythinstall/password_manage.h
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-08-02 21:33:25 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-08-02 21:33:25 (GMT)
commitd3cdc0010fb49666796001edcacbfc408e9b8ea6 (patch)
treeed4aa50356de04cecd5460c8d6b158891ab36767 /abs/core-testing/mythinstall/password_manage.h
parent7224eedb7ce6cc6c4a520cc887c2c5b1eac16191 (diff)
parent9a4b520578e61b098b4dce7a3ba2376c0c74b01e (diff)
downloadlinhes_pkgbuild-d3cdc0010fb49666796001edcacbfc408e9b8ea6.zip
linhes_pkgbuild-d3cdc0010fb49666796001edcacbfc408e9b8ea6.tar.gz
linhes_pkgbuild-d3cdc0010fb49666796001edcacbfc408e9b8ea6.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/mythinstall/password_manage.h')
-rwxr-xr-xabs/core-testing/mythinstall/password_manage.h60
1 files changed, 60 insertions, 0 deletions
diff --git a/abs/core-testing/mythinstall/password_manage.h b/abs/core-testing/mythinstall/password_manage.h
new file mode 100755
index 0000000..665f23f
--- /dev/null
+++ b/abs/core-testing/mythinstall/password_manage.h
@@ -0,0 +1,60 @@
+#include <settings.h>
+#include "mythdialogs.h"
+#include "libmyth/mythdialogs.h"
+#include "libmyth/mythwidgets.h"
+#include "installsettings.h"
+
+
+class UserManagement: public VerticalConfigurationGroup {
+ Q_OBJECT
+public:
+ UserManagement();
+ TransComboBoxSetting *userlist;
+ TransLineEditSetting *userpass1;
+ TransButtonSetting *userapplyButton;
+ TransButtonSetting *usercreateButton;
+ TransButtonSetting *userdeleteButton;
+ TransButtonSetting *passToggleButton;
+ TransLabelSetting *info;
+ TransCheckBoxSetting *lockaccount;
+ HostCheckBox *rootSSH;
+ void user_fillselection(void);
+ bool user_exisit_check(QString);
+ bool user_valid_check(QString);
+
+public slots:
+ void applychanges();
+ void userchanged();
+ void usercreatepopup();
+ void userdeletepopup();
+ void togglepass();
+};
+
+
+
+class WebPassword: public
+ TriggeredConfigurationGroup {
+ Q_OBJECT
+public:
+ WebPassword();
+ HostLineEdit *webuser;
+ HostLineEdit *webpassword;
+ HostCheckBox *webAuth;
+ TransButtonSetting *webpassToggleButton;
+ TransLabelSetting *info;
+ bool valid_check(QString);
+ TransButtonSetting *webapplyButton;
+
+public slots:
+ void webpassword_gathersettings();
+ void togglepass();
+};
+
+class WebPasswordFrame: public
+ VerticalConfigurationGroup {
+ Q_OBJECT
+public:
+ WebPasswordFrame();
+ TransButtonSetting *webapplyButton;
+
+};