summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythinstall/xorgsettings.h
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-17 17:16:35 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-17 17:16:35 (GMT)
commit23303f8dca019bfce8b23517447d8987a3531f07 (patch)
treefffaec25a04fe7c34dc348cfb4572720cc8db1d7 /abs/core-testing/mythinstall/xorgsettings.h
parent997dbedae9ea47fbb46ec15f8827cf1a8065c11e (diff)
parent6361f26251ab679de77f9db79b16632df05a8235 (diff)
downloadlinhes_pkgbuild-23303f8dca019bfce8b23517447d8987a3531f07.zip
linhes_pkgbuild-23303f8dca019bfce8b23517447d8987a3531f07.tar.gz
linhes_pkgbuild-23303f8dca019bfce8b23517447d8987a3531f07.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD
* 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD: Kernel26:Patch for EXT4 data loss. hdhomerun:Updated to latest lib and firmware. mythinstall: add help message for initial res setting
Diffstat (limited to 'abs/core-testing/mythinstall/xorgsettings.h')
-rwxr-xr-xabs/core-testing/mythinstall/xorgsettings.h8
1 files changed, 7 insertions, 1 deletions
diff --git a/abs/core-testing/mythinstall/xorgsettings.h b/abs/core-testing/mythinstall/xorgsettings.h
index b9513fd..4a4ed34 100755
--- a/abs/core-testing/mythinstall/xorgsettings.h
+++ b/abs/core-testing/mythinstall/xorgsettings.h
@@ -105,6 +105,7 @@ static HostComboBox *HostXres()
const int num_defaults = 2;
char *defaults[num_defaults]={"800x600","1280x720"};
int defaults_added[num_defaults]={0,0};
+ int found_modes_in_xorg_log = FALSE;
gc->addSelection("Auto");
@@ -153,6 +154,7 @@ static HostComboBox *HostXres()
strncpy (previous_mode, separator, 200);
gc->addSelection(separator, line_in);
+ found_modes_in_xorg_log = TRUE;
for (int def = 0; def < num_defaults; def++)
if (strncmp (&line_in[1], defaults[def], strlen (defaults[def]))==0)
@@ -166,6 +168,10 @@ static HostComboBox *HostXres()
if (!defaults_added[def])
gc->addSelection(defaults[def], defaults[def]);
- gc->setHelpText(QObject::tr(""));
+ if (found_modes_in_xorg_log)
+ gc->setHelpText(QObject::tr("Choose a resolution to match your display and a refresh rate to match the content you will be recording - 60 Hz for NTSC (e.g. US) 50 Hz for PAL (e.g. UK, Aust, NZ)."));
+ else
+ gc->setHelpText(QObject::tr("Choose the resolution to use when the system reboots."));
+
return gc;
}